Some Wyzec Cam V3s not showing on Nest Hub/Google Home

I have 10 Wyze cameras, some V3s, some V3 Pans, V2 doorbell and one V2. I’ve had my linked to Google Home (and by extension, my nest hubs) for years.

The most recent V3s I’ve added to my account appear in the Google Home app, but they can’t be displayed. All other cameras display fine, including some pan V3s that are newer than the problem cameras.

I’ve tried unlinking and relinking my Wyze account, I’ve tried it with 2FA turned on and off. I’ve verified that all cameras are on the most up-to-date firmware. None are on beta firmware.

The cams show fine in the Wyze app, just not on Google Home/nest hubs.

Any suggestions?

I seem to be able to live stream all my V3 cameras simultaneously in “Cameras” under “Favourites” tab on my Google Home android app. However, if I try to view livestream the cameras individually then it doesn’t work. Funny thing is that I can livestream to my V3 cameras individually on my Amazon Alexa app.

Google Home Android app: 3.16.1.5
V3 firmware: 4.36.12.8391 & 4.36.12.9751 beta

I can livestream to my V3 cameras on my Alexa app.