Sense keypad very slow to respond - like 60s to respond

Using the Android app, the system changes state and responds instantly (arm, disarm, home.) However, using the keypad, we’re seeing upwards of 1 minute delays on arming, disarming, home. The other sensors seem instant (motion and entry), so I don’t think we’re getting any RF interference. Newly unboxed system. 2 keypads, both are behaving the same way. Anything else I should do?


Maybe try uninstalling each of the keypads and then re-installing them with your HMS.

Have you tried using either or both keypads right next to the hub to see if the result changes…

Did you connect the HMS via Wifi or using a wired RJ45 network cable? (At minimum, I would reboot your router / modem if you haven’t already done so yet to let it refresh to help clear out junk cache and also in the event that there are any updates from your service provider, this will give it the opportunity to get it installed…)

Tried all of the below steps

  • Removed keypads from the hub and added them back
  • Moved hub from wired to wi-fi and back to wired
  • At each media change for the hub I removed the keypads and added them back. So that is 3 times adding and removing them.
  • My router is a Fortigate 100E - not anything ISP issued, it is an SMB class router, So it is probably not the issue. Considering all other features, devices, and settings are working as expected - Wyze cameras too, I don’t think restarting the router will do anything towards resolving this.
  • Results are the same if keypads are 1m or 10m from hub.
  • Other sensors do not have latency. Entry is near immediate, motion too.
  • Batteries tested good.

A bit more detail. The latency is just for state change. By pressing disarmed, home, or away; the latency is about 30-60 seconds (random results each time, but always a long delay.) Once I get the acknowledgement via the voice prompt (to enter the PIN and press checkbox) and I then enter my PIN, the state change is fast. Very odd behavior that I think is software or firmware related.


It sounds like it may be time to contact support…

My $.02…I would call them rather than e-mailing them… Support: (206) 339-9646

Memorial Day Weekend Support Hours
Phone and chat support will be unavailable from Saturday, May 29th to Monday, May 31st for Memorial Day weekend. Normal hours will resume on Tuesday, June 1st.

1 Like

Will do, thanks!

FYI: Per Wyze Support, the keypad delay is a known issue and Wyze is looking into resolving this in a future update.

Interesting… Possibly could be an issue that is affecting certain keypads made at specific times/ specific factory…

Maybe. Here’s my hardware details:

  • Model is WSKP1
  • Hardware version is V1.3 (from QR code)
  • Firmware
  • Plugin Version:
  • Both serial numbers start with 00115

Excellent. Thank you for posting the info for your keypad hardware…

Let’s see if other community forum members are seeing something different from what you have posted…

As for me… looks like the firmware is the same… But my plugin version is:

In any event, it is good that you spoke with support… (Have you tried sending in a a log for each of your keypads so that support or engineering can review?.. Go into Wyze support and then “submit a log”

Wyze support just said to wait until the patch, they didn’t need the logs.