Sence Hub will not update firmware

I’ve had home monitoring for over a year, and I’m finally trying to set it up but I cannot for the life of me get the firmware to update on the sence hub. I’ve unplugged, reset it, unplugged all my cameras etc and nothing has worked!

Everything else is updated.

1 Like

Welcome to the Wyze User Community Forum @alshibley!

If it’s been that long since you updated it, it will probably need to go through a couple step updates to get to the latest version. If that is the case, don’t try to do any setup between updates.

Updates are usually quicker and more reliable if the hub is connected to the router via the wired Ethernet port.

You shouldn’t have to unplug any cams or other IoT gear unless you have really slow WiFi or internet from your ISP that is being slowed by client devices on the net.

What version of firmware is failing to update? version. My wifi is fast and it’s plugged into it. It just will not update at all. It just keeps failing.

That is some old firmware considering is the current version.

It has some considerable steps to get thru before it gets up to date.

Did any previous update succeed or is the production shipped firmware still on it. Sometimes firmware updates take a bit of time to settle down before everything returns to normal. The last update may still be finalizing if it was updated previously.

Have you tried the update process from both the Bulk Update Firmware page in Account and from the Device Info Firmware page in the Hub Settings?

If you have already tried a soft reboot (unplug power and hold reset until first lights flash, replug after reboot) and updating from both screens and it still isn’t updating while on Ethernet, you should probably contact Customer Support and get a ticket started:

That’s my next step if someone else didn’t know what to do. I update it every-time I can. But this is just not going through. I’ll contact customer service next. Thank you for your time.

1 Like

I tried the update to my new system hub and it’s offline now.

A ticket had been submitted and I’ll wait to see what happens next though I’m tempted to try some of the suggestions I’ve seen like a soft reboot and factory reboot.

One day it’ll work.

I’ve done both and… nope! Didn’t work :frowning: let me know what they said