RTSP via VLC Media Player

I have the Wyze Cam v2 with firmware I have installed the RTSP file onto my microSD card but I am unable to view the stream via VLC Media Player. I get the following error message:
Connection failed:

VLC could not connect to “192.xxx.86.94:554”.

Your input can’t be opened:

VLC is unable to open the MRL ‘rtsp://Regal1:xxxx@192.xxx.xx.94/live’. Check the log for details.

Do you have the Wyze app installed, too?

Check to see if you can view that camera. If you can, check its IP is still the same.

If the same, check your firewall.

IP address was changed, input new ip still unable to view stream. App is working fine.

Did you change the camera password? Did you check if the firewall is blocking connection to the camera?

How do I check if firewall is blocking connection?? Password never changed for camera

That depends on your router. You might not even have a firewall, in which case, something else is the problem.

Why the need for RTSP? If you think you’re bypassing connection to the Wyze servers, it still does.

This may be a dumb suggestion and I don’t mean to be insulting, but have you actually gone thru the process of Flashing Firmware after putting the Files on your SD card?


No such thing as a dumb suggestion! All I did was copy the file from the forum and follow the instructions as posted. Nothing more or less. If something else needs to be done, please advise. I am a novice at this process!!

I agree about

So you did flash the files after copying to the SD card? The process can be a little tricky with the timing of everything. I think the link I just posted is out of date but here is the current info.
Flashing Firmware

1 Like

i just found that i can vlc stream from two phones, one galaxy s2 (very old), one newer (huawei), but could not get it working on another android phone (oneplusone), don’t know wjat missing

any other good software for streaming?

@Alima154, Did you find a solution? I’m having the same problem.

I did flashed firmware as Tomp suggested, but still not working.

I just figured it out. I turned off my firewall and it worked. Is there a way to make an exception and be able to stream without turning firewall completely off??