RTSP - Handicapped Intentionally? [Solved]

Hello everyone - I’m a bit newer here but I decided to jump in to the Wyze Cams (v2) and I’m noticing issues that really don’t make much sense to me and I was curious if any others have dug deeper into this, and if there is information/resources that change my perspective on the RTSP capability that has been added to Wyze Cams.

From the data breaches to the newly published articles regarding the certificate chain involving Wyze, I’ve really wanted to make an effort to secure the privacy of my family and I as a precaution. While many may think this is a bit over the top, others may understand, especially being born in an era where there wasn’t camera’s or the internet, that privacy is an important part of your life. In order to accomplish this privacy, I wanted to setup RTSP and make the Wyze cams an integral part of that story with the use of internal capture programs (i.e. Blue Iris). I have had nothing but problems, and I really don’t feel that Wyze truly wants this feature to be implemented because it goes against their potential long-term business model.

The issues that I have had with RTSP are numerous, and they compound when you add additional cameras into the infrastructure. In my environment, each is aligned to a nearby WiFi hotspot that provides 90%+ signal to the devices. Each has been assigned an IP address on a subnet that is separated from the primary network, and I have even gone as far as assigning VLAN’s to the devices so they are segregated from an Ethernet perspective as well. No matter what I do, there are constant issues with the dropping of cameras in Blue Iris. No other devices on my infrastructure have this type of issue, and all other devices primarily run on the 5g spectrum so 2.4g is reserved for the cameras (along with channel differences for each hotspot to avoid traffic issues).

I currently have 7 cameras - all of the eventually get to the “No Signal” on Blue Iris. The interesting perspective - the Wyze app works without issues. I can leave the app open, move it to landscape mode, and view all 4 cameras without a single hiccup. They stream perfectly…but for some reason the RTSP feed, which should just be a mirror of this other feed, does not work.

I have read other posts of users that have had to move the OpenIPC or CFW in order to get better consistent results. The drawback for these for me has been the fact that the resolution that the camera allows is only 1600x900, so not a true 1080p picture.

There has not been any another other posts on RTSP in any great detail that I have found in which end-users try to setup multiple camera (i.e. 7+) scenarios and I’m hoping that some of you in the community may have more experience with this setup and what they have done in order to scale out multiple cameras on the network.

At the current state - with Wyze indicating that they can’t include RTSP in the main line, and that it is a “beta” feature (even though it’s wanted by many end-users), and the fact that having a local DVR for the cameras goes against the pay for motion capture services that Wyze provides - just makes me feel that they really don’t want RTSP to work. They added it to just appease some that they had the “RTSP” feature, but it doesn’t really work. No matter what camera, how close or far away it is to the hotspot, all of them eventually start failing with the current RTSP firmware.

I’d really like to have control over the data that is streamed from my home. I’d really like Wyze to answer questions regarding the FUD that is being propagated on the internet right now about the company. I’d really like to get the feeling that they are a secure environment (have you seen the SMS for the 2 factor authentication…even the formatting to me looks very primitive - it’s functional at least). I’d also really like for RTSP to work…that way I can control my data.

Are there others that are having these experiences? Any other thoughts that you have that may help me try to isolate or identify the issue?


I have 7 cams and senors etc. Ive installed the firmware on 4 cams and have tried them on Blue Iris and Blue Stacks with the same result until I enabled virtualization, and then I still had high drop rate. However upon getting mini cam pro, it changed it all… ALL the cams work perfect… I think the problem is Blue iris compatibility… I had to change the codec to H264 but otherwise… runs great

1 Like

@PaulieB Thank you much for the response - I’m going to check that out and report my findings as well. It’s interesting that Blue Iris doesn’t work as effectively.

While I’m at it, might as well try ContaCam as well…

Do you mean “tinyCam Pro”?

Yes sorry. Tiny cam pro.

Tried that as well. No luck. It worked but just ok… trust me I work in an office at home and its imperative I hear/ see deliveries in real time. Staring at a phone wasnt practical. Tiny cam pro works and has cast capability… so I load the 4 cams in and cast to chromecast on a plain cheap TV. Works great. AND. A big AND…I’m in Canada…

Brrrr. Cold.

Well - I’ve made some solid progress and will give an update later. I moved to ContaCam and did a whole infrastructure review and it made an impact.

1 Like

So - here are the main steps that I took to get RTSP up and running with minimal drop outs. I’m thankful Wyze added it but I really hope the add additional options for more control via RTSP for the camera (configurable h264 quality, frame rate, play sound on device, reboot camera, et cetera).

#1 - AP Channel Audit - during my setup I decided to go through another channel audit to see if interference from other AP’s in my neighborhood could have an impact. What I found was that my AP’s were set to automatically choose channels per the router configuration. I have a total of 4 AP’s throughout my house and I was able to segregate the channels to 1, 4, 8, and 11 to reduce interference in my home. Many of the neighbor AP’s ran on channel 6 and some used 11 but were in the opposite area of my house. I installed an app called NetSpot on my phone to audit each area of the home to determine the best channels for that coverage area.

#2 - 802.11b…b stands for bad! - after doing the channel segregation things started to get better, but there were still issues with all devices. I started to focus on hardware configurations next. In one of the rooms, I had an old Linksys WAP54G V1 that had been providing WiFi for my kiddos Chromecast connected TV. It had always ran great for that purpose, and there was only one camera connected to that AP. When I turned off the router, I noticed that all other cameras operated as expected, but when enabled I saw drops. What I also saw is that the Chromecast was actually connecting as 802.11b and not on G or a higher standard. Once I disabled and required 802.11G, the cameras started working much better - until I used the Chromecast at the same time…

#3 - Hardware, Hardware, Hardware - now that I knew this device was an issue - I went ahead and replaced it with a 802.11n 2.4ghz AP - now everything is working as intended for all WiFi purposes in that zone.

#4 - Ask 5 devs how to do something get 10 answers - now that I had verified hardware, signal strength, connection types, I moved on to the software. Blue Iris worked great. ContaCam worked great. TinyCam Pro worked great. Every multi-camera application that supported RTSP worked. After a bunch of testing, I decided to go with ContaCam because of my familiarity with the application.

So, in the end, the infrastructure needed to be combed through in more detail and was really the root cause. I still feel there is so much more Wyze could and should do for RTSP support, but I’m grateful they added it and I get 1080p quality @ 15fps (10fps for night mode) which is now continually monitored on a 8 TB recorder. If you’re having problems, I highly recommend going through similar steps and check your devices that connect to your AP to see if any of those have an impact with your AP, and to have a different kind/brand AP to remove brands as the issues. I run Netgear R6400, R6250, and Airport Extremes on my network and have no issues.


Another update - moved to Zoneminder for my setup - it has been working wonderfully. There are a bunch of buffer settings that can really cause a bunch of issues on the stream (/dev/shm - didn’t even understand the concept until Zoneminder) and the box I put it on isn’t as powerful, but it handles all 12 like a champ.

I’m on Zoneminder 1.32 and will be looking at upgrading to 1.34 which has hardware accelerated decode, but for now it just works. I’ve been on it now for 2 weeks with no camera reboots or drops.

So…ContaCam and Zoneminder have both been great solutions for me so far! :grin:

1 Like