RTSP for V3

Haven’t seen what? I didn’t make any claims. :slight_smile:

Not you, the guy you were responding to.

Sorry, i thought you replied to me. :slight_smile:

Can you share more details? What setup do you use in Blue Iris?

I have been fighting this since day one of the RTSP firmware, with constant drops and reconnects for my Wyze V3 camera in Blue Iris. It can be a bit better if I enable RTP/UDP, but that causes my CPU usage to shoot up, so not ideal and if it goes up 20% for each camera, that is a blocker for me.

Thank you.

I am also curious how you got it to work. I have 5 V3 RTSP and have difficulty keeping all the streams running. I have fiddled with the WiFi for days, with different access points and range extenders. All withing 20 feet of the AP. I would like 2 FPS at full resolution. That would be good enough. I hope they can buff the RTSP up.

Just got some testing results to rule out whether or not I have a bad camera or if Wyze just doesn’t play well with UniFi APs (it does). My testing concludes that the Wyze RTSP firmware is crashing or there is some kind of buggy reconnect request that stalls the camera if there is no internet connectivity (which is the whole point of using RTSP for me).

Wyze Cam V3 RTSP on:
UniFi AP w/Internet (0% packet loss)
UniFi AP without Internet (1.7 % loss)
AirPort Extreme AC w/Internet (0% packet loss)
AirPort Extreme AC without Internet (3.3% loss)

What’s interesting is the rhythm at which it times out when there is no active Internet connection for the camera. It does appear to be running a process that either crashes a service or stalls the camera long enough for a timeout/resume on the RTSP connection.

This stream disconnect occurs approximately every 1-2 two minutes for me, but only when the Internet connection is blocked.

I’m not optimistic about this bug being fixed, but if others haven’t reported any info like this, I’m hoping this find will be helpful.


It’s a known issue. It’s been discussed many times in the Beta Testing forum. Take a look at the links. Let’s hope that Wyze fix this soon.

I’ve had virtually no issues with the v3 RTSP firmware, unifi APs, and BI v with audio enabled. Previously, I had v2 cameras drop off constantly, once or twice an hour or more. I just changed my existing v2 camera’s IPs in BI to the new v3 camera’s IPs, which fixes audio issues some people had from adding them newly.

Is this the newest release of BI, I don’t have any more support, it’s possible there was a fix?
I don’t understand the 2nd sentence, Are you implying simply changing the IP from v2 to v3 will fix the audio issue(s)?

No, I don’t have support either. is the newest version goin by my BI startup logs.

For my first v3 I added it as a new camera and had to change some registry settings to get it to work with audio otherwise it would just crash BI at startup, but I just replaced two v2’s with v3’s by changing the existing cameras and had no issues at all, everything just worked. So maybe that’s worth a try if you have any issues.

Another thing you can try is importing my v3 camera export and changing the IP address (and set up any triggers/alerts etc that you want). Here’s the reg file (but note that it’s not an actual Registry file)

Select Import from exported .reg file and use this .reg file: Upload files for free - Upstairs.reg - ufile.io

For more troubleshooting, here is my current setup for my IoT/camera devices AP:

For my IoT wlan:

And I also use Wifi AI, which is where my occasional disconnects often come from:

I installed the RTSP firmware on a new V3 camera I just got at Best Buy, and no matter what I did I couldn’t get a RTSP client to connect to the camera. I also tried to use the RTSP firmware version to shoot a timelapse, and that failed to save the file, so I think the RTSP firmware is based on a fairly old build, and isn’t working well.

WYZE: you stated that you didn’t want to support two versions of the firmware, but why not give your customers what they want? I suggest you support one version of the firmware that includes RTSP. I love the 130 degree viewing area, and I really like night vision with color. Not supporting RTSP fully might mean I need to move to another camera setup.

UPDATE: I have flashed the latest firmware to the camera again to see if I can get timelapse working

1 Like

The camera streams when I connected it up to an old Linksys router. The problem must be with my Asus GT-AC5300. Does any one have a clue about this router and the Wyze Cam? I do not have isolation turned on in the router and my other Foscams work fine.

I have been down the path of trying to get audio to work with this beta version, it just ends up in a crash/reboot loop of BI. I haven’t tried an import of REG file, but what I did notice that despite changing the setting in the registry, once BI connects to the WC3 it overwrite the change and makes BI5 crash again.

So far I don’t have problems in BI with my v3 and audio stream. I added it as a “Generic/ONVIF” camera and use 64 Kbps a-law for audio. Records audio just fine.

1 Like

What version of bi are you running and what os?

I have BI under Windows 10.

has the release of RTSP been out yet? if so could you like the software where we get it?

The official installation page is here but it is always going to be beta:

1 Like

thank you WildBill.

does the camera have to be on the latest firmware?