Robot Vacuum firmware beta test 1/6/2021

Agree with others about interior walls! I can’t properly separate rooms because it doesn’t see my interior walls as an option. Adding that feature would be a game changer



The base is flat on a wall, though it is a short wall. I may try some cardboard on the shelf on the adjacent wall, it might be reading that weird.

IOS user - I installed Testflight and the beta WYZE app, but I don’t see how to update the vac to the beta firmware. Cameras want to update, but the vac says up to date with 1.6.75.

Me too!! No response on forum either😥

The beta software can be found on the app, Account, About, Beta Program


Says up to date. Reboot app. Reboot vac. out etc. nada

Give it time for the app to alert you of the update. I forget how long it took for me, but eventually I received a notification in the app.

Three days…

You should confirm that you added the products that you want beta firmware properly. If that didn’t work, reach out to support.

See previous message on how to get to this page.

How do i use ketchup.

Did not have the products selected in the Beta program. Changed that and will give it some time.

For the purposes of the Beta firmware 1.6.87 I went ahead and reset my original map that was completed with the original firmware and had the WRV map the primary floor again. The first time I mapped the primary floor I used standard suction. This time I used quiet which yielded an extra 223 ft and 20 minutes from the original scan. The WRV took 2 passes to complete the whole floor. The results of the new map were much more crisp, and the WRV scanned the whole floor as one room. It also appears as if the scan/cleaning was much more precise and efficient in the cleaning pattern vs. the first scan.
Original First Impression here - Wyze vacuum -- good and bad so far - #19 by R.Good

Since the scan was complete I went ahead and split my rooms, not adding any virtual walls just yet, as I don’t have a need since I can perform “area” cleanings…
Before the WRV was having issues with cleaning the Rooms I had created, sometimes the WRV would clean the space, and in some spaces do half and edge cleaning then stop and not clean the full area. I will be testing each space over the course of the next couple of days… So far the first area clean resulted in a perfect execution.

All signs leading to a promising firmware release. I will update this thread as I test.

Update: Area Cleaning for Living Room executed perfectly.
Update: Area Cleaning for Kitchen executed perfectly.
Update: Area Cleaning for Dining Room executed perfectly.
Update 1/13/21: Area Cleaning Back Entry Failed x2. - The WRV got to the circled location and just stopped like it had no clue what to do. It did not announce complete, and did not return to charge. It just sat there wondering what it should do. I had to go into the app and tell it to go back and charge. Each time it found it’s way home.

I pondered for a bit and decided to change the room split the room (The blob at the edge of Room 1 is a chair). The split was in front of the chair so I moved it behind and told the WRV to clean Room 1. It failed again as shown below.


I then moved the split again in front of the chair giving the split some space. After that the room cleaning for Room 1 and 2 executed perfectly.



What I have deduced is that if you have split a room and the split line is in a spot where the WRV cannot make a full line, or it tries to cross over the imaginary room split line it gets confused and it just stops and needs to be told what to do.

ISSUE: (With an adequate charge) WRV stops while executing an area clean and does not return to base

WORKAROUND: Adjust the room split location to allow additional space

I suppose a resolution could be to code that if this happens to indicate a locational challenge, and to adjust the area sizing and return the WRV to the base

In each failed event no cleaning log was captured as well

So at this point. I have mapped the primary floor, split the rooms within the means of the map editor to near my liking ( I would like to make smaller “high traffic” areas in places I cannot today), and executed an area clean for each of those rooms all on the beta app and beta firmware with positive results minus the split line crossover issue that I as able to correct by adjusting the split line.

The WRV failed multiple area cleans using the map created on the previous firmware and app after the firmware and app update. In order for the area cleans to be successful I had to remap the floor with the updated firmware and app.

1 Like

Another item I noticed in the Map Editor.

I wanted to section off the Pantry from the Kitchen. I assumed I could split at the Door (Thick Purple line). I could not. It appears as if you can only split on the Walls (with the splitter utility circled in Orange) where the walls are of the Highlighted Green color (Red Arrows are pointing to them), not the black walls (Yellow X) or dashed light green walls (Other split lines). I even tried to add a virtual wall to make a touch point, but the map editor did not recognize the Virtual Wall.

The odd part is in the standard Map (Not in the Map Editor) the interior walls for my pantry show in the “Highlighted Green”.

Not sure why there is a difference in the maps as to how the app sees the wall from the Standard Map to the Map Editor, maybe something to look into @WyzeAndy

1 Like

I too am having an issue with my Wyze vacuum updating to the new beta firmware. I am running the beta app on IOS, I’ve gone to Account > Beta Progrtam > and selected “Wyze Robot Vacuum”. I’ve waited, I’ve reset the app and vacuum, but nothing is triggering the update. Any ideas? FYI, I opened a support ticket too.

I do not have the beta firmware even though I have the beta app. My vacuum is still showing 1.6.75.

1 Like

I also do not have access to the beta update above 1.6.75. Its been 3 days and the new beta update is still not available for download.

1 Like

I too am running into the issue of not seeing the beta firmware and am stuck on 1.6.75. I’ve put the beta app on both iphone and android phones and checked to get beta firmware for the vacuum (and my wyze camera). Got the beta firmware for the camera, but no luck on the vacuum. Wondering if they have the beta firmware currently not available at the moment is my only thought…or else there is a bunch of us doing something wrong!

I’m in Android beta app and enrolled in the beta firmware for the vacuum but am stuck on 1.6.75 as well. Been constantly checking for firmware updates the last 2 days to see if it’ll give me 1.6.87 since I need to break up rooms, but no luck so far.


I have had similar issues after mapping the entire house, splitting out rooms, added virtual walls and then while trying to clean the vacuum gets lost and cannot find its way back to the charging station and winds up dying on the floor somewhere.

update: I am still having problems getting the vacuum to clean without either getting lost and dying because it can’t remember where the charging station is or without the map creating a ghost map over my correct full map with rooms split out, named and virtual walls entered. I do not want to have to redo the map and start this whole process over. Does anyone have any suggestions or fixes or do I just have to blow out everything that I have done and let the vacuum clean the entire house and then split out my rooms, name them, put up the virtual walls all over again!!! Please advise as this is getting to be a pain. I love the vacuum when it works and sticks to the original maps and cleans rooms by choosing them, but not when it does what it is doing now. Please advise,

I am running the 1.6.87 firmware