RIP: Off-line recording

I am sad to report the demise of off-line recording. Wyze has done something in a recent release of cam firmware and/or the iOS app that killed the capability for off-line recording.

What is “off-line recording”? It’s the ability for a Wyze cam to do local recording (i.e., to an SD card) without having any internet connectivity. I’ve been a big fan of off-line recording since I got my first Wyzecam over a year ago. I’ve made a number of videos while off the grid, in fact way off the grid. @WyzeGwendolyn is a big fan of my time-lapse from a Norwegian fjord. Well, I’m sorry Gwen, there won’t be any more. I just did some testing in preparation for an upcoming trip to far-away places, and was disappointed to find that my recipe for off-line recording doesn’t work any more.

Here’s the set-up I’ve been using. Perhaps other fans of off-line recording will have some suggestions.

When on a trip, I take a small travel router (a HooToo TM01) with integrated WiFi and a 6000 mAh battery. That’s enough juice to power the cam for several hours when ‘on location’. Before departure (while still at home), I connect the router to my home network so it has internet connectivity. I associate my iPhone with the router’s AP (SSID = wyzenet), and run through the usual procedure to add the V2 cam to the Wyze app. By doing so, the cam is configured to connect to wyzenet. Then I power everything down, pack it away, and head off-grid.

At destination, I turn on the travel router, which lights up the wyzenet WiFi network.
Turn on iPhone, and select wyzenet for WiFi connection.
Power up the camera from the router’s battery. It boots up, and associates with wyzenet, since that’s the SSID that it was configured to use.

On past trips, I’ve been able to launch the Wyze app, select the camera, and Live View it. Despite the lack of internet, the app would connect to the camera directly over the WiLAN. I could configure it for continuous recording (to SD card), motion-triggered recording, or a time-lapse. In some locations, I’ve left the camera + router/battery unattended for a few hours while it captured a time-lapse. Subsequently, with the cam and iPhone connected to wyzenet, I could view any recordings, or download/view a time lapse.

But when I tested the set-up today, the Wyze app no longer connects to the camera. It just launches with an aqua screen and a “No internet connection” error. I’ve verified that the cam is indeed connected to the wyzenet WiFi. It obtained an IP address from the router (the same address that it had when originally configured at home). The iPhone can ping the camera. But the Wyze app refuses to initialize in the absence of internet.

If I connect the travel router to my home network again, the Wyze app comes back to life. Unfortunately, in my off-net travels, internet service is not an option. No cell towers, no LTE, no dial-up.

It’s a big disappointment that off-line recording no longer functions. While not part of the Wyze design intent, it was a great ‘hidden’ feature. If anyone has any insights how to restore off-line capability, please let me know. As it now stands, my trusty travel Wyzecam will stay at home on my upcoming trip, and I’ll take an old GoPro for time-lapse capture.


Have you tried the new Beta firmware?

I have not tried the beta. I tend to avoid being on the bleeding edge. Witness the flurry of problems reported with the latest V2 release. I might now give the beta a try if there is evidence that it supports off-line operation.

From your description you used to be able to do it, but I believe you require authorization from the Wyze servers to get a connection to the cam now. That may be to lock down access to the cameras better, I don’t know.

I just did a 9-hour test using my new ‘travel cam’, and I found if I had the cam connect to my iPhone hotspot to get the app connection up and running, then powered down the hotspot, the cam would continue to record to the cam’s SD card indefinitely (or for at least my 9 hour test, lol).

I know that’s not an option for you, but it may help explain what changed, and may help others.


Thanks for the report about your 9-hour test. That’s another use case that I was going to test. It’s good to hear that Wyze fixed the bug that caused the cam to stop recording 1.5 hours after losing WiFi signal. (I ran into that issue a while ago on another ‘off-net’ project).

It’s a shame - the way it worked before made for a really nice mobile solution. It was totally self-contained. My iPhone could manage the cam, view the image being captured, check the quality of the recordings in the field, etc, and do so in locations with no internet connectivity. In such a captive environment, there’s no need for them to ‘lock down’ the cameras better, since no one else has access to the isolated WiLAN.

Wyze told me they are working on this issue and will have a fix within 2 weeks with a firmware update. I just want the camera to monitor my remote camp without any WiFi.


That’s good to hear. Although I think it will also require an up-issue to the Wyze app. From my tests, it seems that the iOS app requires internet connectivity to get past the splash page.

That is hopeful. With that capability and IF they can conquer the 32GB FAT limit it might make it really worth it. Might be able to get 16 weeks of recording with a 512GB ($100) on SD.

I’ll report this to the team to get this on their radar in case there’s something that can be done now or in the future. But I can’t make promises. :frowning:


None expected.
Using the cams for off-line recording is certainly not part of the original Wyze value proposition. But when it works (should say, worked), it made for a really fine portable off-grid recording solution. Totally self-contained, battery powered, with exceptional quality. I was really looking forward to capturing some more time-lapses on an upcoming trip. My GoPro just doesn’t make the grade, since there’s no easy way to view the recorded videos in the field.

1 Like

I’m glad you weren’t expecting a promise. I checked with the team and this is expected behavior that we don’t expect to change in the future. I’ll definitely miss your time lapses! :sob:

I’m very disappointed to hear this, and I know many others will be too. If you’ve been reading the posts here (and I know you have:-), you’re aware that lots of clever customers have been wanting to use Wyze cameras in innovative applications that are ‘off-the-grid’ where there’s no power and/or no internet. In cabins in the woods. In remote camps. In trailers. In cars parked in parking lots. I once mounted a V2 on a telephone pole (temporarily) along with my trusty USB battery pack and captured vehicles driving by (part of a traffic study). Not to mention time-lapse recordings from ships sailing the ocean blue.

Part of the Wzye success (so far) has been thanks to devoted users who keep finding innovative ways to deploy them, mount them, power them, illuminate them, protect them from the elements, etc. The decision to no longer support off-line recording abandons a fertile market segment that in my opinion has a lot of upside. In other words, you’re leaving money on the table.

Here endeth my pitch to revisit the Team’s decision. Perhaps your colleagues will be persuaded. I’m off to devise a replacement recording solution for my upcoming trip. I was planning on using my sleek new limited-edition black V2 for travelogue videos, but it will stay home, alone.


Can you “revert the firmware”?

1 Like

First, I want to take a moment to let you know that this was well-reasoned and well-done. I’ll share it with the team though I’m not sure why this limitation currently exists or if it can (or should) be changed at this point. Thank you for sharing your perspective, kyphos. :slight_smile:


Possibly, but what back to what release?

However, a bigger challenge is the iOS app. If there’s no internet connectivity, the current version hangs at the splash screen with an error, (even though the iPhone has direct connectivity to the camera over WiLAN). Previous versions of the Wyze app are no longer published on the App Store, so it’s not possible to revert back, unless one was keeping local backups of the Wyze apps (and is inclined to jump through hoops).

With the new-to-me FW reversion (under update, have problems) it’s real simple. I tried out 4 in about 10 minutes.
I agree finding old apps is more of a problem. Hopefully they will figure out a way to “authorize” previous versions of the app.

I bought the blasted things to do a certain job. The software AND hardware did it. Life was good. So I bought more. The hardware is the same. Then they changed the software and virtually shoved the upgrade on us. And my timelapse was broke. And all support could do was suggest things like reloading the app, formatting the SD card, clearing the cache, none of which worked for me.

And some people on here like @WyzeGwendolyn, @Loki, @Newshound and you have been great support.


Thanks for the compliment. I appreciate it.

I feel the same way. For me, the cloud recording features are interesting, but not compelling. The 12-second record limit and 5-minute cooldown makes them inappropriate for serious security applications. But the local recording capabilities are (or were) exceedingly useful. A cam on a local WiLAN plus an iPhone or iPad makes a dandy low-cost field recording setup. I’ve left one (plus a battery) mounted on the railing of a ship for hours capturing time-lapses. The cam attracted lots of attention from other passengers (dandy FREE PUBLICITY for Wyze). I’ve recommended them to many people (often total strangers). Those were REFERRAL SALES for Wyze. But as you know, they changed the software, corrupted time-lapse operation, and pretty much killed off-line recording.

I might try reverting back to older firmware load on one of my V2s and see what happens, but for my use case, I think I’m dead in the water since Apple makes it nigh impossible to go back to previous versions of apps. Me bad – I should have been archiving the previous releases of the app on my own.

I’m sorry, gemniii. Like I said, I’m working on helping to chase down the time lapse issue. I don’t see a message from you about it and I’m going out of town in the near future. I’d love to work with you on this next week if you’re available. In the meantime, could you please send in a log after running into the time lapse problem and give me the support ticket number? I’ll shove it at some devs!

I apologize for not messaging you.
I’ve got a workaround

Out of town? Testing the new outdoor cams on Hawaiian beaches? Be sure to go to the North Shore if you are on Oahu.

And I’m due to go out of town next week, so I’ll not have much time for testing new things.

I’m glad you have a workaround! Looks like we wouldn’t be able to get a log from you for this anyway. :slight_smile:

I’m going out of town to hike in the woods and hit people with sticks (I’m doing my first LARP). But maybe I’ll make it to Hawaii someday! I hope you have safe and fun travels.