Problems with Wyze Outdoor Cam and Android App

I have a couple of problems with the Android App and the Wyze Outdoor Cam. These identical problems occur on both my Samsung S20 (Android 10) and my Samsung S7 (Android 8.0.0), so it is not isolated to a single device or Android release. It is a problem in the Wyze Android App.

When I look at the Base Station screen, it shows that I have a 3 bar (full strength) connection.

  1. I record a 1-hour long scheduled recording on my Outdoor Cam. When the recording is complete, I open Album->Scheduled Recordings for the cam and click on the recording. The recording begins downloading to my phone. A typical recording is 360Mb. Before completing, the download will stop for no reason at a random place. The only way that I can tell that the download has stopped is that the progress stops updating. Clicking again on the video has no effect.

So, I click on the back arrow in the upper left, then reopen Scheduled Recordings. The video now shows a Pause symbol. Clicking on it does nothing at all.

The only way to get a stopped recording to resume is to force-close the Wyze app and restart it. When I navigate back to the video, it is still showing Pause. I click on it and download resumes.

It takes several times of doing this to download the complete video. I have over 5Gb available memory in my phone’s storage, so it is not a problem with available space.

If I happen to touch (inadvertently tap) on the video while it is downloading, it will display the Pause symbol. Tapping again on it does one of two things: It may shows the progress info, but it no longer updates, and nothing is actually being downloaded. Or, it may display the message "The device is downloading. Please try again later’. Either way, the only solution is to force-close the app, restart it, navigate all the way back to the video, and click on the Pause symbol. Only then does the download resume.

Further, I switch to any other app, or if the phone rings and I answer it, it is a sure thing that I will have to force-stop and restart the Wyze app, then click on the Pause symbol to once again resume the download.

And - occasionally, the download will simply not resume at all. It is as if there is something in the camera that is tracking the download progress that gets out of synch with what is in my phone.

So, for the entire duration of the download and assembly of the video, my phone is pretty much useless. Over my Wifi, the download speed is about 10Mb/minute. This means that, if I record a one-hour video, my phone is going to be useless for nearly 40 minutes in the best case - usually much longer because I have to keep restarting the download.

Also, it is no reasonable to try to get the video directly from the SD card because the camera stores the hour-long video in individual 1-minute files. I would have to pull the SD card, copy off the segments, and then use a video editing tool to assemble the video. This is ridiculous!

  1. After the video is downloaded to my phone, the status changes to “Loading”. If I navigate away or close the app, the video will be unusable when I return. It will appear to be there, but when I try to open it, the playback screen comes up with the default playback image and nothing will play.

If I navigate to the folder in the phone’s storage, I find 60 .mp4 files, each one minute in length with no audio, and 60 .mp4.aac files. The camera stores the video on it’s SD card in 1-minute segments. During the “Loading” phase, the segments and audio are assembled into the final hour-long .mp4 file. If the “Loading” phase is interrupted, this process does not complete, and will not be completed or restart redone if I click on the video again.

The only recovery is to manually delete the files from my phone and start the whole download process again. If I use the Wyze app to delete the download, it also deletes the video from my Outdoor Cam.

1 Like

Well, it gets worse.

Sometimes, after the download stops for no reason, nothing that I do will cause it to resume. I try gracefully restarting it (just tap the Pause icon on the video in the album). No joy. I force the app to close, then reopen it and navigate back to the video and click on the Pause icon on the video and, again, no joy.

Something gets out of whack either in the app or in the camera, but there is nothing that will download the video.

Bottom line: You cannot ever know if you will actually be able to view a video that you record with the Outdoor Cam.

This is ridiculous!

It got even worse. I could get any recording that went to the SD card (events, time lapse, or scheduled) to even begin to download or be viewable from the app.

I tried formatting the camera SD card. No joy.

I tried deleting the camera and re-adding it. No joy.

Finally, I deleted the base station from my app, reset the base station, reconnected it, then added the camera again. Download seems to be working again. For how long? Who knows.

I have been in software development all my life (I am now over 70). I have never seen software released that works as poorly as the Wyze software.

Seriously, the Wyze software team has a lot to learn!