Please try to power cycle the camera (error code: -90)

I now own 4 Wyze cameras. The first 2 are V1 and I most recently purchased another 2 because of the positive experience and general satisfaction of my first purchase, that are V2.

3 of the 4 cameras all work pretty, pretty, pretty good (TV humor).

A single camera (it’s a V2) gives me the error message (and code) in the subject of my message quite often: Please try to power cycle the camera (error code: -90)

It is, in fact, the camera that sits farthest away from the wireless router. I’m hoping that this is the reason for the error message and not because the camera is of a lesser quality than the other 3. I plan on switching camera positions to test this theory soon.

But if my theory holds up that the message above is very closely related to the camera’s distance away from the wireless router then it’s a “Red Herring” message that places blame on the camera instead of the real issue.

Looking for comments from someone who can shed some extra light on this issue. Thanks.

EDIT: In spite of the distance away from the router, it does work sometimes, but not often enough to be reliable. If it does work, it’s a pleasant surprise, instead of an expectation, right now.

Connection issues due to distance from the router sounds like a plausible explanation. Will be interesting to see the results of your test.

Well, I finally got around to moving the camera closer to the router (much much closer). And, surprise surprise, it works.

Power cycling the camera has nothing to do with the error. It would be nice if the engineering or software teams could make the distinction between the real problem and a more generic one. None the less, the problem is solved for me. Anyone else who finds their self in my same situation might want to know this.

If you get the error message above recommending a power cycle and your camera is a good distance away from the router (50 feet or more) then you can try moving it closer.

1 Like

My camera is only about 10-12 feet away from my router and I get that error message

1 Like

I am just testing V2 just bought recently. It is about 6 feet away but still get this error from time to time.

1 Like

So this isn’t a solution but rather another interesting data point regarding the “error code -90” message.

Yesterday I was reconfiguring my network to make it easier to do packet analysis on certain WiFi devices, and as part of that I set up a couple low-power travel routers as wireless access points (N150 class, 2.4GHz). These pocket routers have a very low output power (around 3dBm) so anything more than 20 feet away starts to lose signal pretty quickly.

I was watching the AP client connections and noticed that my Wyze Cam v2 was dropping in and out, connecting for a few seconds then dropping off the list for 10-15 seconds. I opened the Wyze app on my phone (on the same network, different AP) and tried to view the live stream but I got the “error code -90” message asking me to power cycle the camera (first time I’ve seen this error). I moved the pocket router about 10 feet closer to my camera and it stopped dropping off the client list, and I was able to view the live stream without power cycling my camera.

I repeated the test several times and it looks like any time the camera has a spotty WiFi connection the Wyze app throws that error code. I suspect the Wyze devs could tell us that error code -90 simply means the camera is offline, and the suggestion of power cycling is just the easiest way to force a re-association with WiFi.

I removed the SD Card… Works Fine Now.

    <li style="text-align: left;">Will try another card and Update when I Do..

Dear Wyzecam Moderator, Does this error code mean I have to physical power down and up? Is there any means of fixing the problem remotely? My cameras are all in proximity of strong WiFi signal. I’m using this for remote monitoring and I don’t have the option to physically cycle the power. Is remote monitoring not the most typical application?

Physical power cycle can sometimes be required, but you can usually restart the camera even though you can’t view the livestream. After you get the error code, tap the gear icon and then the Restart Device button.

1 Like

have you tried the “rstart” function in the camera setting ? to remotely restart

Was getting error code 90. Tried recommended fixes found here and nothing worked. My problem was found to be my installation. In trying to keep it tidy. I had taped the camera power cord along side of a household power cord which I believed caused an interference and my error code. I separated the cords and the camera worked perfect.

1 Like

We had our router 802.11n - 2.4 GHz, positioned at a low elevation. We recently moved it to the top of an armoire 1.5m in height (5 ft) and the problem you list has almost completely disappeared.

Hope this helps,



This is a disheartening thread. Basically no one knows the reason the this issue, any where from too far from router, cord interference, one removed sd then it worked, and several mentioned it being very close to router and still getting error. so… this is silly.

I guess what can you expect from a $30 cam. I will try to figure out my issue but I am getting this error code after 24 of working fine so if I can’t figure out - it’ll go back to amazon.

1 Like

Here’s the connectivity troubleshooting guide:

If that doesn’t solve it, keep in mind that this is primarily a user-to-user forum. If you don’t get help here from the community, file a support request including log files. That will ensure that the logs are captured. You might want to submit the ticket right away because there’s somewhat of a backlog. You can always let them know it’s already resolved when they contact you.

this error also occurs when you start to get packet losses due to the inability of the router to keep up with the multiple data streams. Happens often with the crappy modem/routers supplied by ISPs. A big part of the reason Netgear Routers are expensive is that they really can do MIMO multiband not just claim to do it.

I have a Netgear Nighthawk AC2300. My house is not very big. My cameras can’t get very far away from my router. If I check the (Device Info) for (Wi-Fi signal strength) my cameras are usually running between 88% and 95%…
But still on the Wyze Cam Pan cameras I get random ReStarts, error codes -90, -42, 20015, 20016. Countless requests to “Power Cycle” the camera. And lose the ability to Play Back Video. Pulling the plug and putting it back in may or may not bring the camera back. I usually end up pulling the plug and swapping the memory card. Or reformatting the card that was in the camera. That makes everything work as it should till next time. And next time comes way to soon for me to call these dependable.
I really feel after there’s an issue between the cameras and the cards…
I wrote a fairly detailed comment/plea for a solution in the forum a week or so ago. Tilted “Wzye Cam Pan Constant Random Restarts…?” Never had any response to it. I see to many other people bringing up the same or similar issues for this to be something that’s just happening to me.

I can’t speak specifically to the AC2300. I can say that I’ve never had the errors you discuss. I have used MicroSD Cards such as SanDisk ultra for HD video recording. I have found that cheap cards are just cheap. I trust that you have updated the firmware to the current build.

I wish I could say the same thing… Firmware is up to date. The router is a Netgear Nighthawk AC2300 with true MIMO capabilities. I am using 32gb class 10 SanDisk Ultra cards. Should be good enough for any application.
I’m seeing a lot of others mention the same or similar issues. Enough to think there’s a problem. I would like to hear something from Wyze. I think I’ve tried everything I can do from my end. But as I said before I am open to suggestions…

1 Like

I wanted to chime in on this issue as well. I have 4 WyzeCam v2 set up and one of them started coming up with this issue. In my case, the issue seems to have been some file corruption on the sd card. Here are the troubleshooting steps I took to solve the issue:

  • Checked the wifi signal strength around the area using my cell phone and an app like “wifi analyzer”. Pick your favorite app.
  • Checked the wifi signal strength reading from my router. Both router reading and reading from the app were good levels.
  • Tried power cycling by disconnecting from the back of the camera and reconnecting. Same error status.
  • Tried power cycling from the wyze app. Same error status.
  • Tried moving the camera, still same power outlet, just a different spot. Same error status.
  • Tried moving the camera to a different power outlet. Same error status.
  • Tried removing the sd card while the camera was still on. No change, so I put the sd card back in.
  • Removed the camera from the app
  • Factory reset the camera and added the camera back to the app. To factory reset the camera, you need to take out the sd card first. When it connected and I was able to see the live stream, I put in the sd card again. I started getting the same error again.
  • Disconnected the camera, took out the sd card, plugged camera back in. Live stream was back.

Once I figured out there was something going on with the sd card, I loaded up the sd card into my mac book and looked through the files. I found there was a 3+ gig file with unusual characters that seemed odd to me. Also the log files were filled with what I would assume was just junk characters as well, maybe it’s meant to be like that, I hadn’t looked at the files on the computer previously, but that seemed strange as well. I deleted the files and tried connecting the sd card back to the wyze cam. I lost the live stream again. I took out the sd card, tried to format it in my mac book, but it froze up my mac. I finally did a quick format using a windows laptop and connected the sd card back to the wyze cam. Everything was okay, except it wasn’t reading the full capacity of the sd card. I formatted the sd card using the wyze cam app and so far so good. I don’t know if it matters, but I am using a SanDisk 64 Gb micro sd card.

To summarize:

  1. Make sure you have a good wifi signal.
  2. If possible try a different power outlet.
  3. Try removing the sd card and reformatting it.

Hopefully that helps someone.


Just had this problem for the first time. I have four V2 cameras and this is the oldest one - it’s outside (all of mine are) on my back deck. It’s the closest to the router of the four and has worked perfectly since it was originally connected (almost a year ago).

I tried multiple times restarting it from my phone and nothing. Went out this morning and unplugged it from power/plugged it back in/checked about 10 minutes later and - IT WORKED :grinning:

We did have a pretty severe storm on Saturday night - have no idea if that caused the problem but thankful it’s back up and running.