Outdoor cameras one hour off correct time

I have two outdoor cam v2s, three cam v3s, and one pan cam v2. The outdoor cameras are currently displaying 1 hour earlier than EDT even after selecting the option to sync the time in camera settings. The other cameras display the correct time. I am at home with the cameras, so it’s not the traveling issue.

Is there anything else I can do to get these cameras on the correct time zone? The base doesn’t seem to have a time zone setting, but I’ll cycle it just to be sure.


I am having the same issue with 2 of my 10 WCOs. Those 2 are on the same base. I have tried using the “sync time” button and power cycling the base. Didn’t help.

The next step is to try power cycling the cameras them selves. I’ve had WCOs from their start and this is the first time they failed to update for DST.

1 Like

I have the exact same issue. One single outdoor cam (v1), time stamp is currently displaying one hour earlier. This started with DST a few weeks ago. I have a single Wyze Cam v3, and the original Wzye Cam Pan, and both of those are displaying the correct time.

I have the same issue with my 2 outdoor cameras, mine is showing 1 hour late than the rest of my cameras even though it has been time synced. I hope they will resolve this issue.

I have 4 WCOs with same issue. Cameras stay on Universal time–do not change to daylight savings. Do not sync with tablet/phone that are on daylight time. First appeared after a firmware update–not sure which one. Last year they were OK.

Same issue here (US - mountain time zone). Pan cam displays correct time. 2 Cam Outdoor display one hour earlier. I’ve gone through all the steps suggested - clear cache, restart, reset cams, delete cams, re-install them, etc. No luck. Wyze doesn’t seem to be too concerned about this since it’s been going on for over 2 months now. It’s hard to use these as any kind of reliable security cam if the time is not correct.

Anyone have any real response from Wyze?

I just now noticed my Outdoor Cam was set an hour behind the current time. I’m in Central Daylight Time right now. I have turned the camera off and on (via the app), didn’t bother with the cache, and tried syncing about 20 times. Made sure I was on the network (router) I installed them on. Nothing worked. I only have the one Outdoor Cam. My two V3’s are just fine and have the right time. I do not use cam plus in any form. Everything is kept locally on the SD cards. (No video of any kind on the OC) So, this issue still exists.