Outdoor Cam won't charge, appears to have died

I have 3 Outdoor Cams and five V2s. I put the Outdoor Cams up about a month ago and I’m still going through the learning curves, which includes a lot of testing and camera moving. One of the Outdoor Cams was working just fine, still on it’s initial charge, showing 50+% charge. Then all of a sudden the charge rapidly dropped without much recording activity. Went to 20% and then to 10% in a matter of hours. Went to bed and got up to see 0%. Light was showing Blue! Plugged it in using the Wyze provided cord and the Base Station. Stayed at 0% with Blue light. Eventually light went to Yellow. Then nothing. Left it charging all day. No Red light. No charge. Before I declare it dead, does anyone have any suggestions?


Hi @paule That doesn’t sound good. I’d leave it unpugged for a day and try again to charge. In the meantime open a Support Ticket:

Click this link to Click this to Open a Support Ticket

  • Select your product.
  • Type in NONE and NO to all the suggestions until you get to CONTACT SUPPORT.
  • You be able to create an eMail and attach Log Ticket generated from your App.

Try flipping the little switch on the back of the camera off, then on.
If it’s still not working, contact support with the link @dr.know provided or By phone:
(206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT.


I recently bought an outdoor camera bundle when I took the camera out of the box to plug it into sync Battery said 8% it’s been plugged in for almost 24 hours and it won’t make it past 90%. Is there any tips or what should I do next?

@jake.wells , your problem is different than mine. I have 3 WCOs and they all charged up to 100% on their initial charge. I don’t know where they started as I hadn’t added them in the app until after the flashing red light went solid red (Is your flashing red light getting to the solid red stage that indicates full charge?). If it were me, I’d start using it and let it run down a ways (~50%?) and then try charging it up again. I’d try that for a few cycles, paying attention to how long the charge is lasting. As you may have read elsewhere, be sure to charge with the Wyze provided methods to take that variable out of the mix. If you feel you still have a problem after that, I suggest you open a ticket (see info above provided by @dr.know ).

@dr,know and @Brlepage , update on my issue. I opened a ticket. Round 1 of support was to verify that I’d done the basics. A little annoying but necessary and understandable. Round 2 of support was to have me attempt to flash the firmware. When this didn’t work, Wyze declared it a warranty issue and made it easy to replace the camera. Julius from Wyze support was very responsive and professional. Overall it was one of the best support experiences I’ve had in a long time.


Thank you for the update and Solution! Glad to hear you had a good experience with Wyze Julius. :slightly_smiling_face:

1 Like

I have three outdoor cams and all three were working fine — one got down to 18% so I brought it into charge it. It has been blinking red for eternity. It cannot be reached via the base station any more so I assume it died completely unstressed of charging. Basically it is Stone dead. I tried to switch on and off each for days. All it ever does is blank read.
One of the two working ones has a bad USB connector so I have to tape the charger wire to the top of it until it connects and begins to blink red. That one I can tolerate but it’s a pain. That one I assume is just a bad choice of a cheap USB connectors. They’re prone to failure. But the red blinker is a DOA case.As far as I can see—, anybody able to fix that one or is it the return to Wyze ?

My suggestion is to open a support ticket. They’ll likely have a couple of things for you to try before declaring it dead.

Hi @bizibill Have to agree with @paule, open support ticket, number below.
In the meantime, shut off the camera and charge via the base unit overnight.

Live support is available: +1-206.339.9646
Monday - Friday 5 am - 6 pm PT | Saturday 8 am - 4 pm PT

1 Like

Hello Doctor Know,
I finally got the opportunity to make this phone call as you suggested, and waited close to an hour and finally got a person. I said that I have a failed camera and was referred to this phone number for an RMA. The person on the other end apologize saying I’m sorry you had trouble with his camera, and then hung up. Is there a better number or another way to handle this?
I really do need this camera, and rely on it for its intended purpose. But now I am getting worried because it’ll be difficult for me to purchase a new one at this time but if I have no option that may be what I have to do. Can you please let me know how to solve his problem? Thank you very much. I anxiously await your reply.

Hi Bill,
Try calling again and mention you have an outdoor camera, blinking red, and seems it won’t charge. Try and get a support ticket number. Is this camera under Warranty? https://support.wyze.com/hc/en-us/articles/360032425711-How-to-file-a-warranty-claim

While waiting on hold try opening a suppport ticket.

Just type in “Outdoor Camera”, then enter NO to all the questions until you get to Ways to Contact, eMail. I tried just now and it doesn’t seem to have “Outdoor Camera” listed as an option. Worth a try. . .

1 Like

Thanks. Got thru. All solved. Sending replacement.