Outdoor cam will not recharge

I have two Wyze Outdoor Cams, both connected to a Wyze Solar Panel. The setup has worked very nicely for months, but recently I discovered that they were both getting low on battery power. I brought them both in to recharge via USB cable. One charged fine. The other is not recharging. Same USB cable as the first. Checked and double-checked connections. Have tried with cam running and with cam turned off. It will not take a charge. Cam still works. It is at 17% now, but gradually going down. Signal strength to base station is full 3 bars. Tried Reset Services, but that did not help. What can I do to get it to start recharging?

I’d leave it charging for a day or two to be sure, but is this cam still under warranty? It may have a input power board or battery problem.

The first v3 pan I purchased died in about 2 months, so I was lucky as they sent a no charge replacement, and the replacement is going on 4 months now, as it should, fyi. I was also lucky as I got a support person who knew what she was doing too.