Only displays phone numbers in message header

Reviewing my message notifications, only the telephone number appears in the Watch 47 header —- no contact name. This makes it very difficult to decipher inbound messages,

I have a Samsun 20+ phone and have tied both Google messages and Samsung messages. I’ve checked that all permission are enabled on the Wyze app. Is there another setting I’ve missed?


Here is the Wyze response on the Call notification display.

There is a Wishlist item requesting this functionality, give it a vote.

1 Like

Playing a bit more after reading multiple thread comments, the problem seems to be related to the “text Messages” notification switch in the app. Turning that off and enabling “Google Messages” under Other apps appears to allow names to pass through and display on the watch.

1 Like