Notification time incorrect

Whenever I get a notification for a motion alert, the time is 1hr ahead. For example, if the motion was detected at 8am, the notification time shown on my phone will show 9am.

However, the timestamp in the recorded video is correct and live viewing shows the correct time as well. This is an issue across all of my Wyze devices. I have a WyzeCam v2 white, Wyzecam v2 black and a Wyzecam Pan.

What I have tried:

  • Sync time in the app
  • Clear cache in the app
  • Clear cache/data for the WyzeCam app in Android settings
  • Uninstall and reinstalled WyzeCam app
  • On the latest beta for the app
  • Firmware across all devices fully updated
  • My phone time is correct, but tried using automatic network time as well as setting time manually.

None of this works. I’ve been able to replicate the issue on my Galaxy S8+ as well as my brand new Galaxy S10. Has been happening for a while already and I have seen many threads, including on Reddit, about this. Seems like poor coding in the app itself.

None of my other notifications from other apps show incorrect times. This is purely just a notification error on the Wyzecam app itself. Again, recorded videos and live view show correct timestamps.

1 Like

Maybe Daylight Saving Time related? Wonder if it fixes itself on Nov 3rd.

Could be. I think I noticed this issue since DST started/ended (unsure which haha).

The thing is, I don’t have any DST setting enabled on Android. I just choose the timezone +12:00 and that’s it. I synced my time to the devices in the app too, so it should pick up the correct time…?

Set your time to “Automatic date and time”

Tried that already.

OK, but I read that you “choose the timezone +12:00”. That doesn’t take DST into consideration.

“Automatic date and time”, I’m guessing is the provider’s time, really the time of the nearest tower, and should factor DST in.

Yeah, I also mentioned this in the original post - “My phone time is correct, but tried using automatic network time as well as setting time manually.”

I’ve tried setting the timezone to something different manually, and using the automatic network time (i.e automatic date and time) and it’s the same. I’m guessing there’s either a server side issue where the notifications generated doesn’t take DST into consideration, or an app issue, or something…

BTW, I don’t mean to come off as rude, appreciate your suggestions. It’s not a big deal as I don’t check notifications as much anymore, now that I’ve got the email snapshots set up. But ideally, this should be fixed as it confuses me whenever I’m looking at multiple Wyze notifications and have to adjust their timestamps to -1hr to get the actual time.