No Video at the Selected Time with SD Card

Using WyzeCam V2 with latest firmware and official Wyze SD 32GB card purchased with camera and formatted on PC using the SD Card Formatter software and it was working OK for several days. Tonight got “No SD Card Detected” message. Did reset on camera from iOS app (latest version). Even though it’s been set for continuous recording for the last few days for several hours a day, only see “No video at the selected time” for the past few days. Local recording to micro SD card is set to “Continuous recording”, SD card memory available says 1.81G/1.86G.

I’ve noticed numerous complaints on the forums about SD card problems in recording. This seems like a fundamental issue with the camera that should work much better. Trying to physically access the camera to remove the SD card and try to get the video off through PC is a pain.

I was set this week to order the Wyze plugs and a whole set of contact sensors and motion detectors along with more bulbs, but I’m holding off on any more purchases for now until I see if these type of issues ever get resolved by Wyze. A camera that can’t reliably record (even though the software in the app indicates that it should be), no matter what the cost, isn’t worth investing in.


Im going to guess you have an error on the card. the reason Im’ going with this is that in your statement you mentioned it says

SD card memory available says 1.81G/1.86G. the second number after the slash should be the full capacity of the card. have you tried formatting the card since it started saying this?

possible solution. try a format in the camera. if those numbers don’t change, try a full format in a PC.

if that fails I would start a ticket for replacement or refund with Wyze.

Wyze stand behind their products but if you are interested in trying a different card, go with high endurance cards. I havent been able to find an endurance card having an issue in these cameras yet and its what many of us use. this post is a good starting point on whats been working well for people.


Irregardless if it fails you should start a ticket for the SD card replacement. That is one of the reasons I pay a premium for Wyze cards. At $10@ PLUS shipping they are expensive.
Did you try power cycling the camera?

1 Like

In my case, No SD card detected occurred on the first day of installation. Now the company have a process the verify that the Wyze V2 eligible for replacement.
use this link to check with the mac address of each Wyze V2 production line that may affect. I got one replacement.

Since @frob293-39a5x camera work for several days, and the issue may happen many days before you notice. the “no video at the selected time” for the past few days, why not try to view playback to few weeks or few months. It seems like the micro SD card get near full condition.

Please notice that the folder structure of micro SD card store more than footage(video record) . There have Photo, log, Alarm, time-laspe folder which may occupy the whole spaces. You choose read that micro SD card from the PC file Explorer.


I am very very very sure that there is a problem with the micro sd card, change a card to solve the problem. Just changed card, fast and works great in my Wyze Cam v2.

The camera was setup in position to watch a finch that had built it’s nest behind a shutter on my house (Round 2 this summer, and Round 3 from the last 2 years). The mother finch was incubating the eggs and wouldn’t move for a week, and if I got too close, she would fly away for awhile before returning, so I had to wait until the eggs hatched last week to get to the camera.

Test 1: Reformat in camera using Wyze app - no difference
Test 2: Remove SD card from camera, reformat using SD Card program - no difference
Test 3: Try SD card in other camera - no difference
Test 4: Try new Wyze SD card in original camera - works fine for the last week.

Even after the Wyze app “format”, I was still able to get most of the video files off the SD card before attempting reformat on computer. Is there a best way to combine the 1 minute files into 1 file? At this point, I’ll try to submit claim to Wyze to get replacment on the card. I don’t think I’d attempt to use larger SD card as the card is never able to work again in Wyze camera, that’s a big problem.

I’m having the same issue on 3 out of 4 Pan cams that I use. Formatting or replacing SD cards didn’t help. It was working in the beginning after the set up but then stopped working at some point. It’s hard to tell at which point, becuase I received no notification from Wyze app that the camera is not recording any more.

What’s even stranger is that it still records events and show those tiny few second clips later. SO it does store it on the SD card. But it doens’t record playback.

One of the cameras says “No SD card is installed”, which is not true. It is installed and it was recording at some point. It also records short clips as well, so it kinda contradicts itself.

Bottom line - will have to switch to something more reliable if this issue is not resolved. This is a disappointment because I stuffed my house and both business locations with these cameras and they were working great in the first 3-4 months. Hope Wyze can come up with a fix soon.

1 Like

I’m getting this on 2 of my 3 pan cams with high end SD cards. My other 3 mini cams and SD cards are working fine too. Did Wyze ever troubleshoot this for you? Any suggestions for things to try to fix it?

1 Like

Same here!!

I paid for a Wyze branded SD card for every camera and it’s been a waste. They never work for more than a day or two before the camera either can’t find them or can’t play them.

I got the same problem, it works for a few days, but then it stopped to view playback

Is wyze working on this problem. I have 10 cameras and 4 of them do this every few days. I reformat the cards either in the camera or in a pc. Then resetup the camera Someone last night took something from my yard. Both of my front yard cams had no video recorded on the card. This started after the last update. They all worked flawlessly for a year before then. I’m running 128 gig Samsung endurance cards. Wi-Fi is within 15 feet of both cameras. A friend of mine bought several of these cameras because of my suggestion he is now throwing them out and replacing them. This needs to get fixed.

  1. check your wifi signal strength (Device Setting → Device Info)
  2. My latest firmware version is
  3. I have fours Wyze V2 worked very well since Jan2019
  4. If you cannot view Playback (no video at the selected time), please try to view another times or enforce/test the motion action and check
    Event Recording → Detects motion = On
    Detection Settings → Sensitivity and Detection Zone to cover the area you are focus.
  5. If you cannot view Playback and Detection setting is correct, you have an alternative to view via the Events which the clips 12 seconds will be stored in WYZE AWS Cloud storage for 14 days.
    from Home page, choose Events menu, do not choose the camera you want.
    Under the Events page , use Filter to choose the camera, choose the date you want.
1 Like

Well my signal strength is max. One of them sits within 5 feet of the router the other is 12’ thru 1 wall. The ones that are 50’ away work fine. My Firmware is at I’m using an iOS device for my control. The rest is set the way you stated. I have continuous motion capture on. I can view clips if they are caught but there is so much motion that the 5 minute cool down time interferes with the clip capture. When I pull the card after ejecting it there are no clips on it. Some how either when the card fills up and files are written Over it either wipes the files and corrupts the card for further writing or stops trying to write to the card for some reason. I need to look at this more. I need to see if the camera thinks the card is full but it usually says no card installed. Thanks for your help anyway. Weird it worked for a year Without this problem. Regards

If your current Wyze Cam (Pan based on the firmware no) local storage set to Continuous Recording, please try the other option , Record events only ( and format micro SD card after switch to other option. then Restart device)

Most of car camera will record in Cyclic recording in order to save the segment of videos. If an internal battery of car camera is defect and the car has an accident, the last clip which is an important one will not close/save into the sd card.

Come back to the continuous recording method, if the WYZE camera was power off or has some interrupt, the last continuous video clip will not save/write the final necessary status of MP4 . The corrupted file cannot be viewed Playback. Only the recover of MP4 tool may fix the last clip.
Micro sd card of Wyze camera V2 store not only the MP4, but also Alarm, Log, Photo, TimeLapse Folder. the system capture snapshot JPG files into Alarm folder. Please access the micro SD Card with the PC, mobile phone via USB OTG, to verify that there have JPG photos , how many of files and on which date time period stored in the sd card.



FYI about the continuous recording,oldest%20footage%20and%20roll%20forward.

Anyone find a fix for this?
It’s happening to me on multiple cameras with multiple SD cards, even the Samsung pro advance which Is supposed to work very well with security cameras.
It’s not an SD card issue, it’s not a camera issue since that has been replaced too. The camera is within a foot of the WiFi router so not signal strength either.

What is going on with the camera? Why does it keep deleting my footage?

The footage is there somewhere. I plug my card into a data recovery software and it finds the footage up until a certain point where it just cuts out and no more footage.


Same issue. Cards were all working fine in August for playback. Now, utter garbage. All cameras are reporting 56mb/56mb free with no playback availability.

When I first got my camera I used an SD card I had in the house and it didn’t work. So I purchased a Wyze SD card and it worked - for a while. Now I haven’t checked playback in a while because I haven’t needed to but we had some minor lawn vandalism yesterday, went to check playback, it just says “no video at selected time.” I’ve formatted it in the camera and it’s still not recording. I’ll mess with it a little more but I think, based on this thread and the fact that Wyze doesn’t seem to care, that this is just a matter of getting what you pay for… I should have known cameras at this price were too good to be true. If you can’t rely on them then they’re totally worthless. I’ve got a Ring on the other angle of my front yard and guess I’ll be buying a second.


I have 5 wyze cameras and all with the same issue. I think Wyze is doing this to force you to buy Cam Plus.

1 Like

I have two Wyze V2 cams with good quality 32 GB uSD cards (not Wyze) that are able to produce playback just fine. Here are my settings that may be relevant in case it may help someone:
Firmware version: (this has been working for several minor revisions though)
Detection Settings → Detection Zone = off
Event Recording → Schedule = all day
Advanced Settings → Local storage → Record to local uSD = on, Continuous recording = on
Note: I formatted the card in the camera from this menu when I first inserted it. 32GB cards show ~28.8 GB available when freshly formatted
IMPORTANT: Once you have these settings configured, cycle power to the camera by physically unplugging it.