New Wyze Thermostat setup clicking with no screen

Hello,
It may have been answered before but i searched was not able to find the answer. I have tried to install the thermostat it doesn’t turn on i can hear it click and changed the rh wire to rc that didnt work but when i changed rh wire to rc it stopped clicking. I have attached the picture of old thermostat wiring, furnace wiring and new thermostat wiring to help

Old thermostat pic1

Old thermostat pic 2

Do you have a humidifier, dehumidifier, or air cleaner that runs whenever the furnace fan is running? If so, the blue wire that goes to your thermostat isn’t connected to anything, that’s why it clicks.
You need to unwrap this blue wire here and connect it to the “C” terminal on the furnace, along with the other 2 wires that are already connected there,
image

Then make sure the red wire at the thermostat is connected to Rc, and it should work.

Thank you for the response this worked…good eye i totally didnt see that wire wrapped around. The only thing i have concern now is that i have it on AC when it reached the temperature set it still continues to run it says 1 minute but i monitored for over 15 minutes. Any suggestions for that?

hmm. during setup, did you tell it your “old thermostat” has a C wire?

Yes

When it says it’s cooling past the cold temperature, is it running the outdoor unit? it might be a coast to cool setting or similar if it’s only running the indoor blower.

Outdoor unit was running as well