New Wyze gaming headset doesnt work with Discord

I just received the wyze gaming headset and could not get it to work in discord. I set the windows settings to the headset for both speaker and mic in windows and within discord. I’ve tried toggling the mute button but nothing. I heard discord’s noise indicating I pressed the mic and see my name light up but no one hears me.

Games sound fine with the headset. I’ve just been unable to speak in discord. Anyone else having this issue?

Welcome to the forum @mudfly70

I am not seeing this issue, but curious. Are you using the wireless dongle or Bluetooth to connect your PC to the headset?

I will see if I can reproduce or assist.


Blue tooth mainly but I did try with the dongle too.

Right on. Also, there is a Wyze discord too!

I will do some looking here in a few and see what’s up.

1 Like

After trying to set it up for two hours I just requested a return. I’ve never had such an issue with other headsets and I’ve setup a variety of them on Discord before including a cheap $10 Microsoft one. I’ve very disappointed with the Gaming headset. I’ve bought many Wyze products and had nothing but good experiences, so I’ll give this product some time to mature a bit and maybe revisit it in a year.

I ran into an issue with the mic myself, but, it wasn’t with Discord or the Wyze Gaming Headset. The issue was with Windows 11 and the sound settings.

I tested on Windows 11 and Windows 10 Ent

With Windows 10 Ent I have no BLE so it was dongle only. Everything was pretty much plug and play and worked without issue.

All of my Discord settings were set properly and if I went to the general Sound settings on the taskbar everything was set properly as well.

Windows 11 w/ BLE was the challenge. The mic did not want to work. After checking all the normal settings I went a little deeper in the Windows 11 settings. (System>Sound>Properties) I found that the the mic was muted on Windows

If willing, take a look in there.


I am having the same issue. The headset constantly gets the mic and sometimes output set to mute. Even during use. I am also trying to use the my PC/ Bluetooth and my PS5/dongle (Both in the same room) and found out the mfc button does nothing. It constantly switches to whichever is playing audio. This is not how I would’ve expected it to function. Mine will most likely be sent back unless there is a firmware update ASAP. Seems like little to no testing was done with these headphones.