My panscan won’t play any videos

I have had my Panscan for several years. I don’t have an SD card or pay for a subscription. It has always worked fine playing the 12 second videos until a couple of weeks ago. When I go to the events section and hit a video, it just grinds and won’t ever fully load to play. My internet is working fine. I have reset the camera, unplugged and plugged back in, deleted the app and reinstalled, deleted the camera. Nothing is working. Any suggestions?

Your camera won’t record any video events, only images without a subscription. Since this is a pan v1 you can use cam plus lite, which is a pay what you want subscription (even $0) to get event videos.

If you already have that and your events aren’t loading, can you explain the issue? Is it saying failed to upload, is there a green bubble with a ? In it, or is there a spinning loading sign?

Is that something new? I’ve never had to pay before to get videos. No message or anything. It just spins like it’s trying to load and it never finishes. I still get notifications that there is an event and it shows them, but I can’t watch any of them. It started doing this over Christmas break.

CamPlus Lite was introduced a year ago (available for free). I don’t remember when the 12 second event videos stopped without some form of CamPlus.