Messed up cam2 firmware update

I accidentally disconnected my v2 cam during a firmware update and it stopped working. Tried loading the firmware to a card and doing a manual load but so far not successful. Any additional tips for doing this successfully? Thank you.

Here are the official instructions for the V2. Make sure the filename on the sdcard has the correct name, without any hidden extensions.

1 Like

Yes, thank you. I did follow those instructions. The light does turn blue but then after a short time the light changes to a solid yellow and remains so. Im using an off brand 32 gig card. Is using a wyze card critical to manually loading firmware?

Is either one of those BOTH the blue led and the yellow led on at the same time? You may need to rotate or move the camera from side to side to see both LEDs at the same time.


Nope. Any 32 gig card or lower should work.


What did you rename the firmware file to? Double check that windows didn’t hide a file extension causing you to have “.bin.bin” ending to your file.

Named it demo.bin. How does one check to ensure there is not a hidden “.bin” in the name?
As I mentioned, the light does turn blue which I understand indicates it is flashing the firmware but then turns solid and remains so. Every few minutes after that it will click.

To clarify, the blue turns solid yellow and remains so.

I do see the two leds lighting up, the blue and the redish/yellow both on at same time. Then just solid yellow.

I should note the card is a 32 gig SDHC.

Also, i did check for a hidden extension by going to “view” on the desktop and selecting “File name extensions” and “Hidden items” while looking in the card’s main folder.

Not sure if it’s relevant but this is a black V2.

Reformat the card as FAT32 then copy the file. If that doesn’t work, try a different sd card.

Will try a different card.

Tried different cards. No luck. Wondering if using an older version of the firmware would work better on an old V2. Currently available versions only go back to fall of 2023. Are older versions out there?

What version are you trying to use? Just to confirm, Black V2? Also, you are unzipping the file? Sorry to ask such a silly question but many don’t do this.

There may have been some updates in firmware or app that caused older firmware to be incompatible so it was removed to not cause more issues. Just a guess.

You can technically still download some of them, but you’ll need to edit the link yourself.

https://download.wyzecam.com/firmware/v2/demo_*.bin.zip

Replace * with version number for example version 4.9.9.1433 would be:
https://download.wyzecam.com/firmware/v2/demo_4.9.9.1433.bin.zip

Yep, unzipping and following the instructions to the letter. Tried all the available files.

Saw an old post where it was recommended to use an august 2020 firmware release to fix this issue. Anyone know the link for that?

So I found the link to the aug 2020 firmware. Something different DID happen. Now instead of a solid yellow light, it now alternates yellow and blue. But when i hit the reset button while its doing this I dont get the ready to connect message. Any ideas what to do when it’s doing this?