Login fails on Android App

Good day, I have a v3 camera which was working fine awhile ago.
I plugged it back in, and repeatedly tried to log into the Android app and it keeps failing.
I do a password reset.
It sends me a code. I type in the 5 digit code verbatim and a small message box appears on top of the popup keyboard that simply says “Failed” and then it sits at the 5 digit code screen.
I’ve tried this repeatedly without success. It’s not rocket science…is it?

Any suggestions are welcome and appreciated.

First, verify that your login email address (username) and your password are indeed correct on your account by going to the Wyze Website and using those credentials to log in.

You can do that at either services.wyze.com or Account – Wyze

If you are running any VPN software on your device, that may need to be disabled to log in. It may be blocking internet access to the app.

Interesting. Thanks for the suggestion.
I received “Unknown error occurred” and a very long ID code and to contact customer support. Guess that’s next on my list.
I’ve noted this process for future reference - thanks for your help