Live feed freezes

I have a 2nd-generation Wyze Cam, which I use as a door monitor. I have a dedicated iPad (old, first generation) which I use as a monitor. The iPad is set to use the Wyze app to view the live stream from the camera. All of this was working fine, until I had to take the camera down for some construction. When I put the camera back up, and connected to it, there was a firmware update available, which I performed. The firmware is now at
Since then, the Wyze app live stream will freeze with no errors - the video just gets stuck. This will happen after 30 minutes or as much as 4-5 hours. Quitting the app and re-launching connects back to the camera with no issues. When the live video is frozen, I can use my iPhone and connect to the camera with no issues. The camera has good signal strength. The freezing seems to happen more frequently at high resolutions, so I have the camera set to 360 right now.

When I first set this system up a few years ago, I had the same issue, and is seemed to get resolved after some firmware or software update. As i said, this was working perfectly until I had to set the camera up again.

Is it possible to downgrade the camera firmware? Any other suggestions?

That particular firmware is out of date. I would update the application then the firmware on the camera. The current firmware for V2’s is shown below. The current iOS Wyze app is 2.11.41

The iPad app is at 2.11.41, and the camera firmware reports that it is current, so my camera must be a different version than yours.

I actually just joined to post almost an identical issue as yours. I don’t mean to hijack your thread at all, but I am in the same boat. I use my camera as a “baby cam” overnight, and the live feed freezes EVERY night, usually around the same time. I just had a chat with Wyze, who said it’s a known issue that they are working on and don’t have any fixes yet. I’ve done the following troubleshooting steps to try and fix this:

  • Reset and reboot my modem and router
  • Deleted and re-installed the Wyze app
  • Performed a hard reboot of both my iPhone and iPad
  • Reset the camera itself
  • Downgraded the firmware

None of these steps have worked, and I have even had the Wyze app open on both devices at the same time, and it freezes on both. I also submitted my app logs to Wyze at their request. If anyone else has any other suggestions I’m all ears!

Huh, I never had a feed stay up longer than a couple of hours, but I figured it was the fault of the old phone I was using. It doesn’t freeze; it just stops with an error in the app video window. I don’t use it for that but not sure that Wyze is baby monitor “material”.

They only make two versions of the small ones the V1 and the V2. You can check on the device info page.

Yes no errors, pop ups, or anything. I believe two or three firmware versions ago, the app used to crash and close completely. Now the feed totally freezes without any errors, messages, etc.

I agree, it clearly isn’t babycam material, but we use it that way because of the low cost and we have another true baby cam for another kid and if we got a second, they would interfere with each other.

It’s a Wyze Cam v2

Says “Your firmware is up to date!”

And, it is - according the the Wyze firmware page:

Wyze Cam v2 Firmware (March 18, 2020)

  • Optimized the SD card ejection logic
  • Improved Google Nest Hub streaming

I’m not sure why your firmware is different.

I believe mine is beta firmware. I am running the production app so not sure why I would receive beta firmware.

Just another data point.
I noticed just now that the iPad app was stuck at “Connecting camera (1/3) connection attempts: (1 times)”
It repeated that over and over again, with the icon “filling up.” The connection attempts never changed from 1.
I quit the app, and re-launched, and it connected immediately.

I just want to add that i am experiencing this same issue. I own 4 of these cameras and they were working flawlessly up to like 1-2 months ago. Like others here i use one as a baby cam. Twice now the picture has frozen without us noticing and when we realized it was too late and the baby was crying for 15-30 mins. Hope they fix this issue soon.

1 Like

I am also experiencing the same issue on my
iPad and iPhone. I use the Wyze cam as a baby monitor and the camera freezes every night around 2:30am. Everything is updated and I have a strong connection. This problem just started about 1 or 2 months ago.


So I’ve found a bit of a workaround for you fellow “babycammers” that totally does not fix this at all, but IMO, is the lesser of two evils.

I’ve downgraded my firmware to, and the issue still occurs, but now it’s much earlier in the night between 9-930pm. Since I’m still awake, I can catch it, close and re-open the app, and all is well for the rest of the night.

In addition though, on the one amazingly wonderful morning where my kid actually slept until after 9am, it froze again. Once again, it was in that 9-930 time frame. I then left it on the next morning even though he was awake to see if it would do it again, and it did. So for whatever reason, every 12 hours or so, it’s freezing.


This is also happening to me and support had me try a few things and same issue. I just ordered the outdoor cam and would want to have live feed running as well so hopefully they fix this soon.

Same problem. Freezes multiple times through the night.
I have to close the app.
Start the app.
Click on feed.
Click on little square to go to full screen. (Feed appears upside-down)
Turn my ipad over to get the feed to turn over.
Turn my ipad back right-side-up.

Not fun several times through the night. I’m using this to monitor my handicapped son. If I glance at the ipad, he looks fine on the frozen feed but in reality, sometimes he needs help.

Please fix this! Used to work great.

1 Like

My iPad and iPhone app got stuck at “Connecting camera (3/3) connection attempts: (4 times)” It repeated that over and over again, with the icon “filling up.”
I quit the app, and re-launched, and same thing. I removed the SD card, reset to factory defaults and it worked for 24 hours. Now I’m 140 miles away from camera and I can only watch the event recordings saved to the SD card, no live stream. Firmware on V2 camera and on Wyze Pan Camera. I reset the V2 camera to factory default settings with the SD card removed and it worked for only 24 hours, now no live feed.

It has been months since people started to complain about this issue but it looks like it’s still an ongoing issue. Both android and ios devices are stuck at “Connecting camera (1/3) connection attempts every 2-3 hours. I tried several things to overcome this issue such as using a new router only for the wyze cam, a brand new iPhone 13, re-install the wyze app etc. I was planning to buy v3 but this thread already changed my mind about it. My brother was using a wyze cam for a baby cam without an issue for years. He never had this kind of issue. It looks like wyze is losing control with their cam products after they jumped in other kinds of devices. Please care about your customers’ reviews or you’re going to end up as blackberry did.

1 Like

Any resolution for that problem? Feed freeze on all cameras for 5-10 seconds and then continue. This happens every few minutes

I’m not able to understand if the problems with live feed freezing was happening for those effected prior to firmware/app updates? Is it new behavior or did it happen from first installation? Was there ever a firmware version on the cam when it didn’t happen? Answers to those questions might help to eliminate some possible variables.

Just telling users to update their firmware doesn’t directly explain the issue and won’t necessarily fix it while possibly introducing new or additional problems. Like others have said regarding firmware updates, if it isn’t broken don’t “fix” it, as firmware updates are notorious for breaking things that weren’t broken before.

Is there a table somewhere that lists firmware updates along with what Wyze claims the version fixes alongside users’ common complaints about unwanted effects or defects that occurred after implementing that update version? Even if anecdotal, that info could be helpful.