Lamp Socket Accessory Settings - Please Update Camera Firmware (Bug?)

Hello everyone— I need a bit of help! :sweat_smile:

I just set up a new V3 cam with the Lamp Socket— everything is working fine EXCEPT the actual socket settings… I.e. no way to turn the bulb off, etc.

When I go into the cam’s Settings>Accessories>Lamp Socket it keeps saying “Please update your camera firmware to the newest version.”

So then when I check to my cam’s firmware settings it says that I am all up to date (version I’ve tried resetting, turning off and on, etc nothing is working!

I’ve even tried setting up a shortcut rule as a workaround and nothing… The bulb in the socket continues to stay on.

I am running the Android app on my phone (no beta, up to date there too.)

Please help! :pleading_face::pray:t2:

1 Like

Hmm, the latest v3 firmware is This is not the version your on? Are you able to updated through account > firmware updates?

If not, try clearing your app cache in account > app settings. Then force close the app and see if an update is prompted.

If not, you can try manually flashing the latest firmware with:

1 Like

Can you double check your Android app version under Account > About, having an old version could affect that.

1 Like

I have the exact same issue as OP and am running the latest version of the android app V2.33.1 (162)

1 Like

What firmware is your camera on?

1 Like

exactly the same at OP - (version No pathway to updating my firmware recognizes a need for an update - clearing the cache doesn’t help, I’ve combed the other threads and nothing has worked. All the wiring is per the directions, using the usb provided in the socket package.

1 Like

There are a few threads where the firmware is stuck on that version.

I would try manually flashing, but @WyzeJasonJ this seems to be happening more…

1 Like

Thanks for the info. We did locate and fix this issue. Now your V3 should be able to upgrade to the 9.139 firmware.


Literally just did it a few mins ago and everything works perfectly now. Thanks!!


At Firmware 4.X.139, clear app cache, power cycled waiting >20 seconds. Still getting: “Please update your camera firmware to the newest version.”

All - I left this camera and socket powered overnight and this morning, I was prompted to upgrade the firmware. Also, I am unsure if I made an error, but the WyzeCam v3 was firmware upgraded to 4.X.139 this morning. Yes, I thought it was at .139 prior to this. Unsure if I am at fault or otherwise.

With the .139 firmware, the socket is functioning. I even was able to upgrade the firmware on the socket. So, I will keep fingers crossed all keeps going well.