I hate the Wyze Thermostat - ONE TEMPERATURE PLEASE!

Someone PLEASE tell me how to get this thermostat to STAY AT 70 DEGREES… or I’m gonna have to rip it out of the wall and ship it back!

We are constantly HOT or COLD. I am so flipping over this thermostat!

1 Like

Theirs a lot of variables.

What’s your behavior set to?

What’s the temperature differential?

Do you have a temperature preference set?

Is coast to cool on?

Well, for one, I want to be able to set ONE specific temperature. Why the range? The range is FAR too broad… so it’s leaving us uncomfortable.
Behavior: Max comfort
No Schedule
Temp preferences:
Home Away AND sleep all set to Above 69, below 74
Auto Switch is OFF
Lock Thermostat is OFF

I also have sensors in our living room and 3 bedrooms
AND note that those temperature preferences are literally NEVER kept. We wake to the house being 65 degrees. If I select to heat to 70, then it will heat to 75-78. It is literally not controllable.

@SlabSlayer any help here

In the Thermostat, go to Settings–> Advanced → Differential Temp. Set that to 1 degree.

Check to see that all your sensors are included in “Comfort Control”… they should have a house or moon symbol next to them to denote if you want them to be considered in the HOME or SLEEP profile of the thermostat. Each sensor has a Threshold Temperature that you will want to set to 3 degrees.

I also have my sensors set to “Balanced” in the Hot/Cold Spot area of the Sensor Settings.

The range of the HOME profile (as an example) is for Hot Cold… That is to use if you use the Auto setting on the furnace. If you turn on the Heat, and want it to be 70 degrees, the Thermostat will use the “Differential Temperature” to determine if it needs to kick on. If you have sensors, it uses the Mean average of all the sensors that are used in your Comfort Zone… so if 4 temperatures are 72, 71, 71, 70. And you want the house to be 71 degrees… the average of those is 71. The furnace will not kick on. Drop a couple of those down a degree, and it will kick on.

At night, remove sensors in the other living spaces from the Sleep Comfort zone. Just use the ones where you are sleeping (if setup that way).

That’s my quick brain dump. The thermostat is the key to a smart house. When it changes State, it changes 25 Wyze things in my house each time it switches to Home, Sleep, or Away. I love it.

Try that out and let us know.



Great write-up @Earl.Automation . One question, I was informed that the Threshold Temperature on the Remote sensors is not used to adjust the Temp Setting, but rather to determine if the Remote sensor will used in the calculation or not. It may disappear from the included in the Comfort Control if it hits that threshold.

Could be wrong and will reach out to see exactly what it is used for.

But My settings are almost the same as what you listed.

  • T-Stat Differential Temp is 1 Degree
  • Included in Comfort Control: 1 Remote Sensor added in the summer and in the Winter I switch to a different one
  • Remote Sensor Temp Differential: 7 Degrees (May lower to 3 to see if it acts differently)
  • Motion Sensing Comfort: Off
  • Sensor are set to Prioritize Comfort
  • My T-Stat is Behavior is set to Better Comfort
  • My Remote Sensor, included in the Comfort Control is not tied to Home / Sleep / Away, I have it set to all the time.

I like the fact that when it changes you have things change in your home. I may look at that as well.


Thank you for the tag @Rulwiz! Sorry for the delay. Had a long day.

@Earl.Automation and @spamoni4 have already covered so much ground, so I will just share what I have going on with mine…

  • I don’t use any schedules. I also made sure to delete all schedules from the list. All Home\Away\Sleep state changes in my thermostat are rule driven by mode changes in my Wyze HMS security system. There are other ways of automating this as well or you can do it manually.

  • Once a schedule is set, the set temps will not be updated if you change your preference temps. They are independent settings that have to be changed seperately. I really did not like that. I also can’t keep a schedule from one day to the next.

  • If you have no schedules set and they have all been deleted, the preference temp setpoints have to be set for all three states, Home, Away, and Sleep.

  • If you want to have only one temp rather than a range, you have to take it out of Auto. Single temp setpoints are only when it is in Cool or in Heat. When in Auto, It must have a minimum dead range between the Heat and the Cool setpoints so it doesn’t fry your unit trying to switch back and forth constantly between the two systems when fluctuating at that setpoint. It is a safety requirement on every thermostat with an Auto switch setting.

  • At Above 69 and below 74, you are setting the heat to Auto kick in when it gets below 69 and the cool to Auto kick in when it gets above 74. At what temp it starts & stops above and below these temps depends on your Temp Differential.

  • I have my temp differential set at 1°. With the Cool set to 72, it will kick on at 73 and cool to 71. The closer these are, the less efficient the cooling or heating cycle because the system will start more often and run shorter times. The more the differential, the less it will start and stop and will run for longer times. The most wear and tear on your system and the most power used is during startup. Limit the startups and your equipment lasts longer saving you power. You can’t have a 0° differential or the system would be going on and off instantaneously and fry your system.

  • Do not change your behavior setting of the thermostat after you have it set and your other settings changed. Changing the behavior fiddles with all the other settings automatically and you will have to go thru everything else again. I have mine set at Balanced.

  • Auto Switch and Auto are two different things. Auto Switch changes the Home\Away state based on your arrival and departure using GPS. Auto mode will automatically change from the Heat to the Cool state when the temp surpasses the setpoint.

  • The remote sensors complicates things based on how you want them to react to you and to the thermostat. I have mine included permanently. With Motion Sensing Comfort On, I include the sensor (green plus sign). Then I select inclusion for both home and sleep, I click Done, then I turn Motion Sensing Comfort Off. The sensors then remain included when the thermostat is in Home or in Sleep regardless of motion around them. I have my threshold set at 3°. I have the sensor set to Maximize Comfort.

  • The key to recognizing if the remote sensors are included or not, and therefore changing the sensed temp, is by looking at the App. If it tells you “Welcome Home, it is 71 in your Home” they are being included and averaged. If it tells you “Welcome Home, it is 71 in your Wyze Thermostat” or whatever you named it, they aren’t being used in an average and only the thermostat sensor is being used to determine the inside temp. The thermostat face screen on the wall will never show the average temp, only the app.


I most definitely could be wrong in my assumptions on a lot of this. But I feel like I’m right, so that is all that matters in my world. haha. :slight_smile:


LOL, I support your decision and don’t dispute your correctness here. :wink:

I am going to lower mine to 3 degrees to see what happens. Mine maintains the temp. I ask for even at 7 degree threshold.

I am checking to see if we can get a definite answer.



Got an answer regarding the Remote Sensor and the Temp. Threshold setting. What I found out is the following: If the room temperature goes past the threshold you will see a little warning sign in the list of room sensors.

So basically, it does not act as a temp adjustment for the remotes sensor, but more of a condition for when the Temp Exceeds the Threshold on the remote sensor. I did ask to make sure it was clear, and received a confirmation.