How to make the Wyze white bulb stay on all night

How do I set up the light bulb as a night light? I tried setting up a rule for the light to come on at 7PM and off at 7AM. It came on on time, but turned off in 2 hrs.

Welcome to the Wyze User Community Forum @kenkaren51! :raising_hand_man:

You may need to use the “Turn on For” Action or create two rules to get it to work. I have experienced issues with some schedule rules acting wonky when the start and end times are in two calendar days.

Option A Schedule Rule: Turn on for 12h, Set Brightness to ?%, Start Time 7PM, End Time None

Option B Schedule Rule #1: Turn on Light, Set Brightness to ?%, Start Time 7PM, End Time None. Schedule Rule #2: Turn off light, Start Time 7AM, End Time None.

1 Like

Can you post a screenshot of your rule and make sure all actions included are visible please?

Also if you could take a screenshot and post it here of your rules history page which from the homepage of the app you can click on account then rules then the history tab and you should see an entry for that rule and probably one 2 hours later.


As @Omgitstony suggested, post the actual Rule you are using.

Depending on what we see, we could provide alternatives.

One thing that should work as well, is setting up a rule to turn the light on at 7pm and then setup another rule to turn it off at 7am


Thanks to everyone for the quick replies. I tried setting up 2 rules, One to come on, then another to turn it off. The lamp came on on time, but turned off around midnight. Using the app I turned the light back on. It went off about an hour or so later.

Please open each of those two rules and post a screenshot.

Within the bulb device settings, do you have any sleep routines or timers set?

What does your Rule History show for the time period the rules were supposed to execute?

Here are the screenshots you requested. It will only allow obw at a time.

Those all look good. The rules Hx matches what the rules are supposed to be doing.

Have you checked within the Bulb settings for any Sleep Routines or Timers.

Are you using that bulb with any Alexa or Google Home Routines?

I have it linked to Alexa, but no routines. I checked and don’t have any sleep routines or timers. I had ordered Sengled bulbs from Amazon, but returned for the same reason. I

I have some of the Sengled bulbs as well. But since they are only BT w\ the Alexa devices, their use is somewhat limited.

Not sure what might be turning your bulbs off though.

I checked again and rhere was a routine set up in my Alexa. I deleted and will see if my lights will stay on all night. Thanks.

1 Like

That may well have been it. Hoping they work!

Worked great! Thanks for all your help.

1 Like

Awesome! So glad you found a solution!