How to I get Wyze Support to actually read a support request?

I sent in a detailed Support Request that included a link to a video of my Wyze Robot Vacuum infinitely going in a circle even though it was in no way obstructed.

Felrei Alejo from Wyze Support responded by asking me to send him a video. It is clear that he didn’t even bother to read my message, which wasn’t long, but was detailed.

I reminded him (her?) that I had already sent in the video and he (she?) requested that I set up a virtual wall. Why would I need to set up a virtual wall in the middle of an open room where there are no obstructions?

He (she?) then suggested that I crate a room. Why would I need to create a room when the mapping app clearly created the room, and he (she?) would have known this if they had bothered to look at the map that I already sent in the support request.

It is very clear that Wyze Support (or at least Felrei Alejo) is too lazy to actually read customer Support Requests. I know that some customers are vague, unclear, or don’t read. But that isn’t my case. I was detailed and provided a video in the first message.

Or, is the purpose of Wyze Support to just frustrate customers and make them go away?

How do I get Wyze Support to actually read and respond to my Support Request?

Yeah, support in general can be frustrating, especially since we’re already in a frustrated mood before we contact them, so our levels are already elevated.


Most companies make their support agents follow set scripts, sometimes nearly exact responses they have to give and sometimes that may make it feel like they didn’t read/listen to you, when they did, but they have to say it anyway. Don’t let it get to you too much, they just have to follow the procedures as close to exactly as possible or they get low scores on their quality control, which can affect raises, etc. Some companies allow more flexibility and discretion, and while that helps in some cases, it often causes more issues in other cases. It’s a hard balance, and it doesn’t matter too much…just work your way through the things they tell you to do even if you already told them you’ve already done it. If it’s something you absolutely know doesn’t matter and you’ve already done it, just respond politely that you did as they requested and that it didn’t work. They probably know you already did it, and they probably know it is pointless, but they HAVE TO ask you to do it anyway. besides, sometimes there are people less competent that simply misunderstood something, so they have to ask people to try again just in case. Even though it doesn’t apply to your situation, if you’ve ever worked in IT or helpdesk situations, you’ll know that 99% of issues are what we call an ID-10-T error.

ID-10-T: There was an error in the keyboard-chair interface. Please replace with valid user and press any key to continue.

The fact that you do not fall into this category, and the loop isn’t your fault in any way, doesn’t mean they don’t still have to walk through all the steps because even people who make mistakes never believe that’s the problem either, and 99% of the time basic troubleshooting scripts solve the issue when done in the same order every time…so now all support departments require their employees to walk through everything anyway, even if the people say they’ve already done it and the agent already knows you already did it…they still have to tell you to do it, and it looks like they ignored you, when they’re just following their mandatory scripting because companies found it usually works. Just roll your eyes, take a deep breath and understand it’s just the way things are almost everywhere because of too many other people who aren’t as tech savy as you, so realize you’re just going to have to placate them because they’re just saying what they are required to. Some agents for some companies may not even fully know what they are asking you to do, they’re just following their script. You have to get through it though. Once you do, then they’ll either pass on your situation to someone with more expertise, send a replacement, or whatever else is needed…but step 1 needs to be completed first…just get it done. Many years ago I used to work in this field doing training, QA, supervisory situations, etc…and often the agents are simply bound by the policies and scripts and they’ll get in trouble if they don’t follow them exactly even if they know it will upset you…and half the time they don’t even know how to answer you about WHY something they’re asking you to do is supposed to help, they just know a script asks you to try it.


1 reason why they are suggesting you set up a virtual wall in an open room is because that has solved some people’s issues with this exact situation. I’ve had discussions with people where their vacuum got stuck in a cycle for whatever reason. It may have been the pattern on the floor or many other things bugging out the firmware, but when they put a tiny virtual wall right in the middle of that cycle area, it could no longer continue on in that cycle, and so it had to restructure the planned route in a totally different way and suddenly the vacuum worked correctly with a new pattern that stopped looping because the loop was blocked. This is simply one work around while they figure out a better solution in the long term. There are other less optimal solutions (put a strip of black tape in the middle of the loop area and it works just like a wall too). If you divide that big room into 2 separate “rooms” it will have the same effect. Now in the map, it will view and calculate the route everything differently, but still clean the entire area. You won’t really notice much difference functionally, but it will kill off the loop problem.

You aren’t the only person to have looping issues…but he really is telling you the best ways to resolve the loop without making physical changes to your house. Yes, it is a bug in the firmware that they need to isolate and fix…but I assume you don’t want to wait MONTHS for the devs to figure out what coding conflicts are causing the weird loop issues…you want your vacuum to work NOW! Those are your best options…interrupt the loop. divide that room into 2 rooms on the virtual map, with the division right in the middle of the loop area, breaking up the loop. Or add a small virtual wall. Or put down some black tape in the middle of the loop area.

If your flooring has a lot of dark lines or patterns on it, that could also be the problem. Dark flooring triggers the cliff sensors to spazz out and think there is a cliff (like stairs). This is another reason they may have asked for a video, to see if this is the problem. You can cover the sensors by taping shiney foil over them, and then it will never spazz out over dark patterns, but then you have to make sure there is nowhere they could fall down because it will no longer sense places it could fall.

Sorry for your frustration. Though it is rare, you aren’t the only one having looping issues, though we haven’t yet received any explanation as to what is causing it, all we know are a few workarounds and those are the things he was trying to help you try out (since those have worked for others). I hope some of the above helps in some way. Worst case scenario, you can always try to return the vacuum for a refund.

Best of luck.
(Also, I don’t work for or represent Wyze in any way, just trying to help with my experience and what I’ve read from others in similar situations who were able to fix the issue)


I appreciate your explanation.

Part of what I found frustrating was that my initial report INCLUDED a link to a video of what was happening. Despite this, I was requested to submit a video. I checked, and the submitted video was never downloaded. This, of course, clearly indicated that the “support” person reached for the “Blow this customer away with canned answer #1” without having given me so much as 15 seconds to actually read my request. While 99% of most customers may be inarticulate, there should at least be the obligation to read what is written since it takes 10x as long to write as to read something.

This particular room has a solid Burgundy colored carpet. The looping is inconsistent and may happen in several places. It will loop until the battery is low, go get a recharge, come back, and then loop somewhere else. It’s a $4,000 carpet that may get worn out quite quickly.

Should anybody care to see it, here is the link to the video of it looping:
Wyze Robot Vacuum Infinitely Looping
(Valid for 7 days)

The vacuum seems to have several design problems:

  1. When docking it will not mate with the charger consistently. It gets “real close” but misses. I think it tends to push or tip the charger module over a bit.

  2. It gives a lot of useless notifications, even thought they are turned off. I really don’t need to be woken up at 4AM to be told that the vacuum has only 8% battery and that I should recharge it soon? (Why do I have top recharge it soon. It should do that…why is it even bothering me with this notification?

  3. It likes to rid up onto baseboards. It is able to walk along a baseboard on only one wheel, sliding the other side up about 3" on the baseboard. Not cool!

  4. It likes to go under toe kicks and cabinets where it then hits its LIDAR head and gets stuck. Can’t it see these things coming? They are level, square cabinets.

Thanks, for the clarification, that was helpful.

I can totally see how frustrating that would be. Everything you said seems to have been entirely ignored. Like you said, there wasn’t even any download, so it was obviously ignored, especially since the immediate question was to send the video, which you already did. Makes me realize there is no point in being well articulated in the first email in the future, I’ll probably just keep initial contact short, then elaborate after they respond the first time.

I did download and watch the video you listed bytheway. After talking with other people having this issue, I was interested to see it happening.

I took a screenshot here (FYI: since you set up the video to expire in 7 days, if you also want the picture deleted from here later, I will of course respect that and delete it from here at your request; since it seems to not have any identifying info, I assumed it should be fine to show here):

For others interested, you can see the lines in the carpet in a long somewhat reverse S shape it keeps looping around. Very interesting.

Have all the past loops been in this exact same location?

Does it do anything differently if the movie case and stuff under it are not there?

I don’t think your carpet should be the problem, though I wouldn’t rule it out. I mean, it does change from a light color to a darker color and causing some lighter or darker lines which theoretically could be tripping up the cliff light sensors underneath.

If you get it to loop again, try messing up the carpet lines in that area after it passes and see if that changes it. If it makes a difference, I am wondering if it would be possible to do something to change the cliff sensor sensitivity a little (tape some plastic wrap over it or something to increase the opacity, but not fully take it away).

Anyone else have ideas for this particular loop?

I have had the vacuum get stuck under stuff too. I have heard that other lidar robovacs also have the same issue. Something about how the lidar itself hits up to the level of the lidar itself, but then the casing ontop of it goes a fraction of an inch higher than they measure, so there is a small zone where an object may be higher than the lidar, but lower than the cap/ceiling that goes over the lidar, and so anything in that range causes lidar robovacs to get stuck. They would have to do something like add another bumper sensor on 4 sides of the lidar cap to account for this and it’s complicated, so most suggest we just add virtual walls (or black tape boundaries) to resolve that issue. I have to do this for my daughter’s desk and some cabinets too.

I have found the best support with WYZE comes from calling the the support line vs. entering a support ticket, should you have the time, Wyze Support by phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT

But actually a lot of the best support comes from right here in this community :slight_smile: there are some real sharp folks here, welcome.

Can you share what the map looks like when it gets into the loop? I can’t imagine you have a room split there in front of the cabinet (I checked out the video). Where I have actually seen where the WRV gets confused in the middle of a split room line.

I noticed my WRV would have some issues if I used a map built on a previous app or firmware version. I have got into the habit of running a quick map after each update, just for good measure. Have you tried a remap since you have been having the looping issue? This could be a good troubleshooting step if you have not done it recently and of course make sure you are on the latest firmware, which I am sure the WYZE tech mentioned.

1 Like

Agreed, just call them

I did capture the map while it was looping. Here it is:

It doesn’t reliably loop here. It finds many different loops to make, all throughout the house. I find them by seeing the repetitive pattern with (usually) the rest of the room unvacuumed.

As for the LIDAR, I am sure that there are multiple solutions. One that comes to mind is an upward pointing ultrasonic sensor in the front. Or, a camera. Or a cliff-sensor pointed UP. I am sure it’s solvable.

This is a nice house, The carpet in this one room was $4,000. I am not thrilled at having pieces of electrical tape stuck around.

It also has interesting behavior on hand knotted carpets. Not much problem with it swallowing fringes, but it can act a little frightened by some patterns.

I have also seen where there is a black sock on the floor that scares the daylights out of it…won’t go near the sock.

It has a consistent problem at the top of the stairs. It detects the cliff just fine. But then it follows the cliff edge until it hits the top newel and then can’t figure out what to do. Seems to be a generic problem with the software…any time it travels with the cliff on the left-hand side of the robot it travels to the newel and then feels trapped.

I really would have thought that these problems would have been solved at this stage of development. These things aren’t new. Xiaomi (the real manufacturer of the Wyze vacuum) has a large installed base in 中国. So I don’t have a lot of sympathy.

I am somewhat surprised that these robots don’t have two cameras and mostly depend upon stereo vision like we humans do.