How to fix "you're not on the same network" for downloading timelapses?

So it seem that bottom line don’t connect any Wyze cam to guest network in thinking of keep your internal network safe from potential hack. Lol

PS, I run dual router setup for that.

1 Like

Hm. in my case it is not guest network, it is the same network as both camera and phone. Surprisingly enough, that iPad on the same network is able to download timelapse, but iPhone - not. Same app, same network, same firewalls…

1 Like

Sorry this was not helpful in your case. But good thing is that you just narrow it down to your iPhone being the issue.

I know for android not all device are equal or work the same. example: android devices all have limitation on what version android os can be install which then dictates what version apps will work on said system.

I used to be IOS user but proprietary and limited customization, even with jailbreak made me jump ship.

I would compare your iPhone to your iPad. See if both Wyze app are same version. Then log into your router and make sure both devices show up in same network and subnet. Make sure the Wyze app has permissions to access IOS pictures gallery.
Turn on location just in case Wyze app used it in background to verify something. There got to be something the iPhone is preventing the app to see the same network.

Good luck

So, there is confirmed bug in the iPhone app then?
I have exactly the same issue.
I have triple checked that they are indeed on the same wifi network.

Same issue here. A few month back I was able to download time lapse video in Wyse app; now I get the message “not on same wifi network”.

This is definitely a bug. All devices are on same network, nothing has changed on my side but Wyze app and cameras’ firmware versions.

Thanks for the suggestion to turn off Mobile Data. That WORKED for me! I could see the time lapse video in the Album but it would fail to download and ask me to verify that I was connected to the camera. After disabling Mobile Data, it downloaded it just fine. I never would have guessed that would work.

1 Like