Help with Wyze Scale Apple Health integration

I can’t see any input from wyze scale in apple health app after allowing 3rd part integration.
How to sync data so that it can reflect on apple health app.


UnOfficial. But the data I find is from the specific weight points. Maybe go through a dig around. Maybe your favorites are not what updates and you need to edit. I am enjoying my use with the Apple system.

@charnjitsaini I’m unable to get the Wyze data to show up in Apple Health at all. I’ve tried all kinds of toggling in both the Health app and in Wyze.

I’ve never been able to get it to work.

Anyone have any luck?

It is working for me now, after syncing couple of times and after on day it is showing now.


Hey, Did you ever end up connecting? Would love to help ya out if ya want to zoom or something.

No luck whatsoever.

I’m unable to get the Wyze to send any data to Apple Health.

Everything is toggled on but the last weight update is from myself entering it.

Will it only send a weight point if the iPhone is connected to the scale? Or will it dump a backlog?

Now. Did you look on the previous days data and see if it populated there?

Yes, nothing shows up.

The last weight in Apple Heath was ages ago when I entered it.

1 Like

I have the same problem. all categories enabled and no data in Health app. tried uninstall and reboot but no luck. any luck getting it to work


Hey, Can you confirm your iOS device and iOS Version for me. Then on the app itself. Make sure that you have updated the app to the most up to date version. If your device is not running the most up to date version of the iOS. Be sure to update it.

Personally. I have a 6 Plus that is nearly 6 years old and it runs the app and health app fine. But I would also suggest just restarting the device and maybe power cycling the scale and reattaching after a power cycle. Remove the batteries for 30 seconds.

Let me know. Again. This is just personal help and I am not an employee!

For some reason it took 24hrs and then started replicating. Never sync’d day 1 but everything moving forward worked fine

I had to reset my iPhone and somehow lost all health data even though I backed it up. Is there any way to sync past Wyze scale weigh ins with the health app?

Scale is not syncing with Apple Health app. It used to and it seems to be hit or miss and currently, it’s not syncing.

Can you confirm. That you’ve logged into the wyze app after using the scale. Had the scale update on the Wyze app and then gone back to the fitness app? I was noticing this. But then I had done this and it fixed the issue.

I think I know what’s happening, I held my phone in my hand while I got on the scale and a popup asked if I was who I was, pressed yes, and then the app updated with the weight and then the Apple Health app updated. I’m guessing it’s been asking this for all those dates that the weight is not being recorded. Is there a way to turn off that user verification?

1 Like

Super happy it connected.

I’m having a similar issue. I’ve had the scale since April and integration worked fine until Aug3, when it abruptly stopped. I haven’t been able to get it to sync since. All apps up to date. Ask firmware utd as well. Any advice? It’s driving me nuts.

@WyzeAlex should be able to assist you.

Thanks. I’ll reach out

1 Like

@WyzeAlex. Can you help me troubleshoot this issue with my scale and Apple health? Thanks!