Apple Health Sync Stopped Working

Apple Health syncing has been working with no issues until now. The last data synced was on Nov 10. I have tried unauthorizing Apple Health in the Wyze app, removing the Wyze data source in Apple Health, uninstalling the Wyze app, rebooting my iPhone, re-installing the Wyze app, and re-authorizing Apple Health in the Wyze app and Apple Health app. I still cannot get any new data to sync. The scale is syncing with the Wyze app, I just can’t get the data into Apple Health. I am on the latest iOS (14.2), the latest Wyze app, and the latest scale firmware.


I have the exact same problem.

My morning weigh in synced today. So, I guess all the “troubleshooting” I did at least got new data syncing. I’m still missing all of the history which includes each day since Nov 10 (when the sync stopped) plus everything since I got the scale, since part of the troubleshooting included deleting the Wyze data from Apple Health. The history is still in the Wyze app. I have no idea why it won’t sync with Apple Health. In the past, I could got a few days without opening the Wyze app, then, when I did open it, all history from the last opening was synced from the scale and to Apple Health.

I have the exact same problem. No weight stored since October 14, to December 14.

Exact same issue here. Wyze app stopped pushing data to Health App since Nov 6 and I still cannot get it to work after several troubleshooting steps i read on the web (including this community).

Same problem here except syncing stopped on 11/13/2020. I worked with customer support through all the same steps noted above, nothing worked. Final exchange was “send us the data logs for the scale” . All the data prior to that date is still in the Apple health app. The Wyze app works fine.

I had a similar issue where Wyze stopped syncing starting Nov 11 or so. I got it to start sending data to Apple Health again (starting Dec 14 when I realized), but since then other apps that pull the data out of Apple Health don’t seem to be able to do so. (ie. Withings Health Mate) I’ve reauthorized everything, turned permissions off and back on again, reinstalled Wyze app… nothing seems to be working yet. Today after doing some more troubleshooting, today’s weight info hasn’t transferred to Apple Health…

Following. Same problem as other users. My last update was 10/15/2020. Syncing has since resumed but none of the data shown in Wyze app from October to current is updated to iOS Health.

I have same problem nothing since Nov 6th and authorizing IOS Health did not solve the problem. All of the apps are the latest version. The Wyze app has recorded and tracks the data but it is not linking.
After spending the last couple of months trying to keep a home automated with Wyse sense I have to wonder if the scale is the next obsolete product.

@WyzeGwendolyn Any advice on getting stored data from the Scale into Apple Health? Seems the issue is not uncommon.

Same issue here. It was syncing with Apple Health for months then stopped on 2/9. I checked and found that Apple Health was no longer authorized. Why would it randomly become unauthorized? I authorized it again, but the missing data has not synced to Apple Health yet. How long will that take?

Now also a victim of this. Just now noticed it stopped in min January and I can’t get it to being syncing.

@WyzeGwendolyn Any help on this issue? I’m missing 6 months of data in Apple Health because the Wyze app turned off the integration at some point last fall…

Still having this issue, would love an option to re sync all previous data

I’ve run into this multiple times now. I find that it often occurs around the same time as an app update. Something in the update switches the 3rd party integrations to OFF. Get in the habit of checking it after any app update.

1 Like

No sync with Apple Health since November 2020

If the app gets updates and, in particular, makes you sign in again then you need to turn on the 3rd party sync again. It seems that this is often rest to OFF.

1 Like

I have these same issues. I’ve tried uninstalling, making a new account, etc. nothing is working.

My wife has no issues syncing her data from the same device

1 Like

The same thing happens to me, it’s quite frustrating to have to re-connect 3rd party apps every time. I thought it was just certain versions of the app, but it happens EVERY TIME the app updates.

Wyze randomly turns the Apple Health syncing. It’s been doing that for 3 years now. Wyze a response is crickets! Supports response is check app version, delete device and delete app and reinstall it all. What garbage!

What you have to do is go to Apple Health and make sure you turn off Wyze and turn is all back on. Then you have to turn Wyze back on to sync with Apple Health.

I’m tired of lost data. This service does me no good without stable and consistent data. I’m dumping Wyze asap and going in on Apple. Will slowly replace Wyze cams etc as well. I’m sick of it.

Also the support never gets back on what the cause it when the service person escalated the issue. Just pure garbage service and poor product quality management.

I screwed up when I went all in on Wyze. Should of known better and stayed with the big dogs like Apple or Google.