Firmware upgrade for Wyze cam makes my cam not work with MEMU emulator

I’m using MEMU emulator and I just upgraded the cam firmware from to and now my cam will not connect. I shut down and restarted Wyze software. Can doesn’t work. I pulled the power plug, waited 10 seconds and reconnected. Cam doesn’t work. I tried another cam and it works on the old firmware. I upgraded this cam. and now it too doesn’t work, even after restarting the software program and power cycling.

I guess the new firmware upgrade doesn’t work with MEMU emulator. I upgraded MEMU emulator and the two cams still don’t work. Can somebody please tell me how to go back to the older version firmware which worked just fine? Thanks. Oh yes. The cam works fine after the firmware up grade on my android phone. But I need it to work with my pc and MEMU emulator.

Have you upgraded the Wyze app within your emulator, or not? You seem focused on the firmware when the problem is on your app within that emulator.

I’ll check that out. Didn’t think of that. I always get prompts to upgrade firmware, never the Wyze software. Thanks.

This problem I’ve encountered in the past. I can’t upgrade to latest version of the Wyze in the MEMU emulator. The app doesn’t appear in Google Play although it appears in Windows Google play but my emulator is not listed in the devices to upgrade, just my android phone. So, does anybody know where I can get the apk file for the latest version of the Wyze app.

Of course. The two most reputable places I know are APKMirror and APKPure. Use whatever trusted source you got it from in the first place.

Also, restarting the emulator / virtual phone might fix your current issue anyway.

I’m trying to upgrade the WYZE cam app in MEMU emulator but the app doesn’t appear in Google Play in MEMU. Can somebody please advise where I can get the latest version of the Wyze app apk file so I can sideload it into MEMU? Thanks. is the direct link to the app, it should tell you if your device is compatible. You could in theory use apk mirror but the direct link should get you to the app.

@Raymond I already answered you above.

Kitten I’ve never found that kind of “direct” Play Store link to work. All it ends up doing is prompting you to log in.

Are you saying that if you provide Google account credentials it will install the app without the Play Store installed?

To use the play store you need a google account.

Didn’t exactly answer my question. :wink:

You need the playstore any to install items from the playstore, you need a google account to use the playstore. Given that the Play store is a stock app provided by google it should be installed.

Yes. But there are lots of Android installations and devices that don’t have Play Store / Google Play Services installed or supported. It’s far from a stock app universally.

So your direct link method may be only a workaround for those who are being blocked in Play Store for a particular device type. It sounds as if Raymond does fit this category.

Those without Play Store, those without a Google Account, and/or those desirous of less Google tracking still have to sideload from a repository.