Event video playback blocked

I was forced to update the Wyze app last night as it said my version of the app could no longer be used to play event videos. After update, I cannot play event video snippets for most of my cameras (seems mostly the v2 cameras failing). Events seem to detect ok, but when I attempt to play the video snippet, I now see only a static thumbnail with a (new) play icon. When I click the play icon, I get a pop-message that says “Video events are available for Cam Plus devices. To use this feature, please go to our Services page and assign a service such as Cam Plus to this camera.” Under the Service page, I see my service (Cam Plus Lite), and all of my cameras are listed. The page will not, however, let me do anything to change the assignment for any of the cameras (e.g. to remove and then re-add them).

Tried multiple things to restore. Reboots of phone, cameras, turning off and then on the event recording. No joy.

I spent a long, slow hour on chat with support this morning, which ended with ‘submit a log’, but the support person would not honor my request that someone contact me once the problem and resolution was determined. I was told to “just keep an eye out for future app and firmware updates” (?!). Needless to say this was not an acceptable answer. My camera system is greatly impaired without the ability to view events as they occur.

So, has anyone encountered this problem and found a solution or workaround? I saw similar cases in the forum, which suggests this is a pervasive problem showing in multiple failure modes. Re-adding the cameras to the service and reconfiguring events seemed to help some cases. I can (and did) alter the event recording settings, but I am blocked from doing anything in the Services page to attempt a fix.

Any ideas would be appreciated.

1 Like

I have the exact same issue with my V2 cameras. IOS app, latest firmware. I didn’t bother contacting support, because support has never done anything with any of the bug reports I’ve submitted. Instead of fixing things, they just add more bugs that render the whole system useless:

  1. endless nuisance notifications
  2. bricked sensors
  3. events no longer work
    … I imagine the next update will brick the cameras.

Wyze is garbage, sell your stuff while you can still get a few $$s for it.


For Android app, just delete and sideload older version.

You will be ok. wait for new app release. just submit lots of logs using new app before you uninstall.

1 Like

Thanks much for the suggestion. I did find an archive under apkmirror.com (hopefully safe), and started installing older versions to find one that would avoid the problem.

I did not find an older version of the app that fixed the problem I was seeing, but in the course of testing, I noticed some camera settings were altered, and that turned out to be the problem. One of the updates, I think the recent forced update of the app (~Nov 20), altered the “Recording Type” setting on most of my V2 cameras. Manually checking and redoing the settings restored the event recording.

I did not find an older version that fixed the problem I was seeing, so I suspect it was something in the Wyze update process that was corrupting settings. I was able to remain on the latest app version after restoring my settings. That may be a good heads up for others generally, so I will post another thread for this.

Thanks again!

I don’t see the “recording type” setting you’re referring to. I tried toggling “record all motion events” and “record sound events” on/off, but that didn’t fix the problem.

1 Like

Since posting, I have discovered that the “Recording Type” option has been removed (or maybe hidden somewhere?) in the latest version of the app (v2.37.1.134). I have not done any experiments changing the config from that latest app version so I don’t know if there would have been a way to fix the specific problem I was seeing using the latest app version.

Using the older app version v2.29.0.114, I attach two screenshots to show what I see now after fixing the config. In my case, I installed the “BlueStacks” emulator on my PC and installed this older app version from “apkmirror” (disclaimer, I cannot vouch for any of these third party sources, so use them at your own risk). This allowed me to keep my phone at the latest app version, and like you, I do not see the “Recording Type” option under that latest version.

I hope this helps.

1 Like

Yes, I have the same issue. Wyze use to be an amazing company but alot has changed over the past few years. Their system seems to have more and more issues and have become very unreliable. I guess that is how all great company ends. I’m looking for other options. There are ton more better options nowadays than before. I guess people has to leave before Wyze wakes up.

1 Like

I agree. It’s just so sad to see once a great company turn into X in just a few years. They could have been the leader in the market.

I can’t keep up with the bugs. It’s like one a week. endless

The company has made it a paid feature to view 15-second event video previews. It’s not a bug. Which means the cameras you currently have now have been rendered practically useless & have fewer features than when you first bought it unless you pay for a subscription.

Here’s what their help chat agent says:

For the record I checked my emails from wyze and have never received a notice about this change.

Also, i did buy a cam plus subscription - except as soon as I applied it to my camera, it will stop detecting anything. Endless hours with CS did not solve the problem.

Can you imagine a company whose product is so rubbish that paying customers are forced to not use a subscription because it stops working as soon as they paid?


Wow… so all the people that bought cameras that were supposed to have (limited) event playback available for free can no longer get what they paid for when they bought their cameras? Unreal. That’s probably lawsuit worthy.

Guess it wasn’t a bug after all.


I came here thinking this was also a bug but only to find out this was intentionally done. This is false advertising. It may say something different now but when I first bought my Wyze cam it DID NOT say you need a subscription to view your events. This is definitely class action lawsuit worthy in my opinion.

1 Like

Cam plus lite is a pay what you want subscription, even free. If you were enrolled in the legacy person detection program, you should have been automatically upgraded to cam plus lite with no charge. You can sign up for cam plus lite right now for $0 a month, and get the 12 second events back plus person detection.

Thanks, definitely didn’t get the memo on that, and something seems to have gone wrong with my auto-subscription. I’m subscribed now, but am now back to the original bug where it shows there are event videos to play, but they don’t load.
Glad I didn’t pay anything for the subscription that doesn’t work properly :roll_eyes:

When the Wyze App says I need to update, I always skip the update and see if my version still does everything I need it to do. Then I check the Wyze forum to see what users are saying about the newest version before I update. Yes, it is best for security reason to update, but I would rather be one or two version back if the latest is going to break a feature I need.

BTW, I have an old iPad with an old version of the Wyze App I use strictly for Wyze testing. If a newer version (maybe not the very latest version) is acting weird, i go to he old iPad to see what it is doing. BTW, the old Wyze App still plays Event videos and gets AI notifications.

1 Like

That’s a smart way to do it. Wish there was a way to roll back updates on IOS :frowning:
Or while I’m wishing, I wish Wyze would stop breaking things in every update.

I am getting very upset about Corporations and Wyze.
The people are wary about government but pucking greed corporations checking you every click you do on internet!
yes we need class action lawsuit.

It is always greed that kills a great company. Don’t worry another replacement company will be here soon.

1 Like

I have the latest iOS version, 2.38.4(3) on an iPad Pro (15.1) and on an iPhone (16.0.2). Events play back fine on the iPad, but on the iPhone, I just get a spinning wheel of wait. Cam Plus Lite account only. This feels more like a bug than anything else…

1 Like

Very interesting! How do we go about reporting bugs?