Event recording too late

I’ve noticed that motion events seems to begin recording from the moment the motion occurs… is it possible to save a few seconds before the motion, to give a little extra context (sometimes there is undetected motion that occurs before the event recording, so this is missed when playing back events)


The event notification videos should actually begin about two seconds before the detected event. Have you tried adjusting the detection sensitivity and/or detection zone?

I’m seeing the same thing. The thumbnail timestamp can be several seconds before the event video starts. Reformatting the SD card seemed to help before, so I’ll probably give that a shot. One camera is particularly bad, but the others are usually starting the video at the same time as the thumbnail.

I’ve never had an issue with my Wyze cams alert recordings. Until right now my front garage and door door cameras started recording after the delivery guy was walking back to their vehicle. The snapshot was accurate but the motion recording was not. I rebooting the cans and if it continues i will reformat the sd card and see if it resolves.


It would be great if the 2 second buffer could be configured… detection sensitivity/zone wouldn’t help in my case (I get way too many false alerts with detection any more sensitive).

I’ll try formatting the SD, but this has been happening since the camera was new and a fresh new card wasn’t installed.

I’ve noticed since the latest app release of 2.1.21 I used to get alert video a few seconds before the event. No longer, if the event is shown at all I count myself lucky. Usually I get a boring, unmoving scene with no understanding of why it triggered.

this was a problem with a friend of mine. turns out his sd card was had the incorrect write speeds we need. a fairly simple fix for him indeed

I must ask what SD cards you guys are using? there seems to be a common issue with certain cards EVEN if they are rated for the correct write speeds.

I am also experiencing this problem, some events start 2 seconds (approx) before the movement trigger and other events start too late so there is no movement shown in the 12 second clip even though the thumbnail shows a person or vehicle (these are both happening on the same camera). This has only happened since upgrading to firmware 4.94.28 and it started straight after upgrading, so I struggle to see why the SD card is at fault. I am using Kingston Micro SD SDHC memory Card Class 10 32GB. Any help would be much appreiciated. Apologies if I’ve missed something as this is my first post

you say its not caught on the 12 second clip, but is it recorded at all on the sd card? all my cameras are updated and my clips are caught good and the actually recordings on playback give me a good 5 seconds of clip before the movement that triggered it comes on. whatever you’re capturing, how fast is it moving?

1 Like

The SD card records permanently so yes the motion that triggered the event is recorded on the SD card. I use the cloud recording to assess whether I need to troll through the SD card for the extra footage, however I often get a person or vehicle displayed in the thumbnail on the events page but the 12 sceond cloud recording has missed the entire event. I occasionally get a fast moving car that will be missed which is understandable and acceptable, however a person walking down the steps to my front door should never be missed. As stated previously this did not happen when the cameras were new, it only started after the firmware upgrade. After reading other posts I have now re-formatted the SD cards (I have 2x Wyze v2 cameras) and will see if that makes any difference although I am doubtfull as the problem is with the cloud recording which does not require a SD card.

1 Like

have you sent a log into the dev’s?

1 Like

No not yet, this is my first time looking for help as the cameras have been awesome until this issue, so I thought I’d start with the community. I will build up some evidence to help them and send a log. Many thanks for your assistance

1 Like

we do what we can. if you get a solution don’t forget to post that. it might help others if the issue arises in the future. :slight_smile:

Hm, need to see if this has changed. In the past, there was always a few seconds “buffered” before a triggered event - and SD card recordings seemed to be on the full minute (I only record “events” locally) and for the full minute.
And just checked; mine cameras seem to have a second of two of recording “before” triggered" event.

Yes I always used to get a second or two of pre-event recoridng to the cloud, however I am regularaly getting an event with a person or vehicle shown in the thumbnail yet the cloud recording is too late to catch the event. I have emailed Wyze support for help so I will let you know their response when received.

OK, Wyze support have been in touch and rectified the problem so in case anyone else is suffering with events being missed on the cloud recordings here is the solution -

Re-flash firmware using SD card
Here is the link to our support article that will walk you through performing a firmware flash on your device - Wyze Cam Firmware

Please go back to the previous version - [V4.9.3.64]

After this please factory reset the camera
To perform a Factory reset on your camera, follow the instructions below:

For V2 and Pan units (V2s will be indicated as WYZEC2 on the white label)

  1. If using an SD card with the camera, remove it before proceeding.
  2. Leave the unit plugged in and power on.
  3. Press and hold the setup button on the bottom of the unit for 10 seconds.
  4. Allow at least 30 seconds for unit to initialize, in some rare instances this process can take up to 5 minutes.
  5. The LED status light should move from Solid Yellow to Blinking Yellow.
  6. The device is now ready to be setup once again.

Set-up the camera by following the original instructions

To confirm - following this procedure rectified the problem instantly, I can only assume there is a bug in firmware V4.9.4.28 so I am leaving my firmware on V4.9.3.64 until the next one is released.


1 Like

Another update to this issue - I have installed the recently released firmware version: and the problem immediately returned. The cloud recording starting late not 2 seconds prior to the start of the event.

I would be very interested to know if anyone else is experiencing the same issue?


@wales2fresno; zero issues with event recordings as far as I can see (and never have had).
In fact, SD card saves seems to be in “even” 60 seconds segments. So if an event triggers detection at i.e. 17 seconds past the full minute, I have SD card recording from 1 second all the way to the 60th second. If event continues, recording continues in full 60 second segments (not talking about the actual files) until motion is no longer detected. If last motion is at 45 seconds past full minute, recording will stop at 60th second.

Many thanks for your informative input. My issues have been with the cloud recording not the SD recording. The latest firmware revisions are regularly missing event recording to the cloud due to the 12 second recording simply starting too late. The result is a vehicle or person shown in the thumbnail on the Events page however when you play the 12 second cloud recording the event trigger (vehicle or person) is leaving the picture as the playback starts (ie the cloud recording is starting too late) . This probelm seems to exist on all firmware versions released after (v2)

I’m having the same issue. The cloud recording is starting a few seconds to late. I haven’t tried to roll back the firmware. My camera is running It would be nice if Wyze would resolve this.