Echo show detects wyze cam but wont show on display

Hi and welcome!

Usually if your Echo Show, shows you the waiting for Wyze screen and then goes back to its home screen that means the request timed out. Could be a network issue. Can you see the camera live view on the Wyze app on your phone? Are your Wyze and Echo on the same WiFi network?

Yes…no issues on the app. The “waiting for wyze cam” message only appears on the echo show screen for approximately 2 seconds then just goes back to the homescreen.

I run into this myself once in awhile. I would keep trying every now and again. It seems to be slow to make that first connection sometimes.

I’m have the same issue and nothing work for me

1 Like

Usually if it persists it indicates a bad network connection somewhere. Or even a misconfiguration.

I tried everything… Reseting modem router wyze cam alexa app and noting work

I would suggest opening a support ticket with either Wyze or Amazon.

For Wyze you can open a ticket here


Thank you… I did that already… Now waiting

1 Like

I have the same exact problem. Did you receive an answer yet?

Sorry for the late respond… Yes, I did have an answer… In alexa app just disable the wyze cam for 5 minutes and enable and that’s it


Thanks for updating us! That’s actually useful info for the future! I have a Ring Video Doorbell 2 as well as 10 Wyze cams and they usually connect to my Echo Show relatively quickly. But every now and then they have a wobble or two. Will try that next time either is stubborn!

1 Like

My cameras worked right away when I connected them to Alexa but only for 5 mins. Then exactly as you said it says waiting for Wyze and goes back to home screen.
When I disabled and enabled again it still didn’t work… I’ve done it 3 times already

I have the same issue. Hooked the Wyze cam up to echo show 8 and worked fine for a couple mins. I could see the feed on my show. Just says waiting for Wyze and then says sorry there is a problem and returns to home screen. I’ve tried disabling from Alexa app and then enable, made sure show 8 was on 2.4 network. Even removed device and set it up again. Still not luck displaying on echo show 8 but can see no problem on the app.

Disable it from alexa app for 10 minutes and enable it back

1 Like

Hi I’ve logged into the skill for Wyze, I have all updated cameras and I have Alexa control on my Samsung tv. When I ask to see a camera it starts it but nothing shows?

1 Like

I’m having issues with that as well. It will pop up for a second then disappear but I still get sound.

I’ve done all of the above steps but still am not having any luck getting video on my Echos. I can here audio but no video. (It says “camera name” is not responding). My Wyze cam v3 works on the echos but not the regular cam. Does anyone else have this problem?

The Echo Show 8 is about a month old. When I enabled the two Wyze cams and a Ring doorbell they both “showed” on the Show as expected. After a week or so the Wyze no longer do but never had an issue with Ring. I have disabled the skill for 10 minutes and re-enabled, The Wyze cams work fine in the Wyze app but not thru the Show.

I have a Echo Show 10 Gen 3. Purchased it because I thought I read somewhere that I would be able to show one or multiple Wyze Cam’s on it by simply saying “Alexa, show ‘Back Yard Camera’ “. (I haven’t had time to research or follow up on this at all…or I grew tired of trying to get it to work… perhaps both).

Thanks for asking the question….

I have a WOC in my front yard, facing my front door, and I created a rule where if the WOC detected motion, the Echo Show would start streaming from the Wyze Doorbell Camera…. (that quit working for reasons’ unknown, and I’m going to see if I can get that working again today)

Ideally, I’d like to see my Echo Show 10 stream my doorbell cam 24/7. Perhaps there is a reason that is not feasible?

I’d also like to see my Echo display a grid of my cameras… 2x2… 4x4 or any multiple camera view that makes sense on a 10” Echo Show.