Echo 8 Won't Show Live Feed

This is probably not your problem and will not help. But I suspect you will try anything. And I am not suggesting you make all these ideas permanent. Objective is to find what works, right? And maybe you have already done all these. In that case, this is also for anyone else that is having a like problem and is looking for some ideas.

  1. (I’m not going to ask you the names.) But be sure you are calling for the correct camera to the correctly-named Show. Mine for instance are named Echo Show 8x where x is the number. Sometimes in a routine, I forget to add “Echo”.

  2. Next, I guess you are running these from a routine? If so, add an “Announcement” (recently renamed from “Send Notification”, so you know the routine is in fact/actually running. Even if just the camera’s name and which show it goes to. AND don’t send the announcement to the Show that you are trying to get the camera to show on. Use another echo device. (I do this on all my camera routines - don’t send any announcement to the target Show.

  3. Are you using Smart Plugs? Can you “borrow” one from some other arrangement and use it with that camera? Add the Smart Plug, - don’t make it part of the routine, (but I guess you could if you really want to). Set the routine to tell the smart plug to turn off, so the camera is off, for 3-4 min at least. Then turn the camera back on with by turning the Smart Plug back on in the same routine you turned it off. Now using voice or schedule, tell that camera to send the view to the Show.

  4. Try a separate routine, and run it before you tell the camera to send to the show, I am saying Reset the Show with this command string. “Alexa, Go Home” Run it from a routine, And you make the “Go Home” the last command added using the Custom choice in the routine. As you know it adds “Alexa” to the beginning of the line. And I also add an Announcement so I know its occurring. Take just a couple of words to know the routine is running/has run.

  5. Last What generation are your Shows? I have both 1st gen and 2nd Gen. I have spent more than a reasonable amount of time, fussin’ and cussin’ to learn that for the last few versions of firmware on both/separately V2 and V3’s, they don’t like 2nd Gen Show. Let me say that again. I am successful most of the time 80+ any given time, getting V2 or V3 to display on a Show when I am using a 1st Gen Show (only a 1st Gen Show. I have some 2nd Gen Show. I don’t even bother to use them for a Wyze Cam.

Who knows (not me) why only 1st Gen are working. I know, to test it was not just me, I went on Amazon and drilled down until I found a renewed 1st Gen 8 and bought it, trading in an old 2nd Gen Dot, to get a 25% discount, just to add another 1st Gen Show 8 to my stuff. And it works.

If you have a question about any of these suggestions, reference the # so we can make it easier to talk about them/it.

1 Like