Did WYZE ever figure out the high failure rate of V3 cameras?

Bought my first V3 3-16-21. It failed eventually a few days after a power cycle and update. (stuck on solid red light, unable to reset, new firmware from sd card does not fix). 7-24-21 I get my replacement cam. It failed the same way. 8-5-21 I get another replacement for the replaced cam. Some theories suggest updates kill them. Others say power cycle does. I did not perform any updates and the last cam ran continuously on uninterruptable power supply. It did last the longest but just failed yesterday 2/16/22. I noticed it was a bit laggy yesterday with connection issues so I restarted the cam through the app without unplugging it from the power supply. Today I noticed it is a total brick with solid red light on like the others. I still have a little time under the original warranty.

I know they will most likely send me another one however did they ever figure out what causes this? Despite giving me replacements I never got an explanation for the failures and got the impression that they could not care less. They never wanted any of the old cams to see what happened and they always made it seem rare. I have seen many others having the same problem yet other say it’s been great. I am thinking about getting something that lasts longer than a few months because it’s mounting location is a pain. I have old V2 cameras that still work from the same location but I like the nighttime video of v3’s. I am unlucky but I can’t imagine that I am this unlucky lol.

I think you can be that unlucky :rofl: I have one V3 and it has been outdoors running continuous for 1 year and eight days. The only time I have turned it off was when I connected the power to a Kasa smart plug and tested the plug out.


I think it’s you. I don’t recall hearing anyone having that kind of failure rate. Personally, I have 14 V3 cameras dating from as far back at 12/31/20 to the newest on 10/13/21. Other than one that I killed while doing an external antenna mod, all are fully operational. Most have been power cycled many times, Additionally, I install every beta firmware version that comes out for the V3 into all of my cameras, so most have at least several firmware updates. All of them were uSD card loaded with RTSP firmware and later reverted back to normal (beta) firmware.


I am up to 11 V3s now. The first was brought online on 10/16/2020. I have not had a single camera die for any reason. Every camera is updated within a few days of a firmware release. I just think you had a run of really bad luck.

Sorry, I know this doesn’t really answer your question.

1 Like

I have to say, I’ve had nothing but bad luck with my v3 camera. It’s been replaced three times under warranty and the last one recently failed exactly like the previous 3. Wyze sent a notice about a software update and I agreed to the update. My three year old v2 worked fine, as it’s always done. The v3 went belly up with a solid red light after the update. I’ve tried resetting and flashing them with no luck. Very disappointing.

1 Like

I had more issues with V2’s failing than V3’s - I have 16 V3’s and they all work fine.

:exclamation: :exclamation: Knocks on wood repeatedly :exclamation: :exclamation:

I would say your router is making your cams fail,we have over 89 cameras in service at alot of locations and have had no issues in over 2 years

A red light isn’t necessarily indicative of a problem. A solid red light is used even in correct working conditions. Mind you, there are various bumps eg the sd card firmware won’t work with certain sd cards. Unless you have used that specific sd card before for the firmware update to know that it will work, its not indicative of a failure in-of-itself.

Unless they don’t do file verification or unless it loses power mid update or they pushed out one that happened to brick them, the update shouldn’t ever cause a failure. Power cycles also won’t cause failure in-of-itself.

But there’s also not enough info here to go on. A solid red light says next to nothing if even that much.

I understand you powered your V3 on a UPS, but I can think of a couple circumstances that might be the source of the problem. (1.) Despite the UPS, might there be an occasional power surge? (2.) Is any of the wiring (120v AC supply, or 12v DC) loose or being loosened by some action?