Detection Zone Not working (doorbell pro)

Hello,
I’ve tried to contact wyze support but didn’t find it helpful, posting here to see if other people are experiencing similar problems, hopefully, I can hear a solution.
I’ve noticed detection zone is not obeyed by my doorbell pro for a couple months, it’ll trigger events outside of the zone. This is super frustrating as it drains my battery really fast and made the notification really often thus useless.
I’ve attached how I set up my zone as well as some example recordings. (you can see i intentionally deselect 1 row to avoid any possible overlap on the sidewalk)
I don’t think any pixel within the zone is changed during the event. also I’ve tried to only show 1 pixel but still got recordings!
This makes me wonder if the detection zone is even working, but please let me know if you have any guesses why it triggers events for me or if there’s any solution for that.

Thanks!

I can’t upload video but these are some example videos where those cars drove outside of the zone and triggered recording.

another example of people walking outside of the zone.

I don’t see that anyone responded. I have the same problem. I’ve also played with the sensitivity without success. I’ve gone all the way to Low and it misses my mailman walking right up to the camera, but it catches me opening the door to get my mail. Pretty sure the detection settings are pretty much worthless.

I started having the same problems when I changed the detection setting a few days ago. Thing was, I never used the detection zone feature, and my doorbell is oriented the same way: looking out into a street. It sometimes picked up vehicles driving on the street, but not often, but then I turned on detection zone while turned sensitivity to 4 from 3 and now It’s picking up A LOT of traffic. I’ve tried to limit the zone to just at the front porch and pulled down the sensitivity to 2 but it’s still picking up the cars. I have no clue what’s happening with the software at this point…

I had two packages delivered today. One from Amazon and the 2nd from the USPS. The Amazon package delivery was recorded on video. The USPS package showed up with no video evidence. This is with Detection Zone turned on and Sensitivity at 2. Looks like I have more adjustments to make. :man_shrugging:

I got the doorbell last month and have the same issue - the detection zone settings do not seem to work - the camera picks up from the entire field of view.

I’ve had the same problem since I bought my doorbell pro almost two years ago, and I’ve brought it up a few times before. Apparently, there is no fix for this if you’re on battery power. The doorbell “wakes up” and starts recording before checking the detection zone (or something like that). It’s not something they can fix. The best solutions I’ve heard so far was to switch to using power (which defeats the purpose of buying the doorbell for situations that don’t have existing doorbell wiring). I wish they would print that little detail on the doorbell packaging/spec sheet, so people could know before buying the doorbell, and then wondering why detection zones are being ignored. Something simple like “Note: Detection Zones do NOT work when used on battery power only.”

This is infuriating, since I had this problem since I bought my doorbell in October and Wyze Support has been systematically wasting my time over this for 6 months by failing to provide this simple detail.

When I installed the doorbell, it prompted me to update the firmware. Then it didn’t respect the detection zone, so I opened a support ticket. Wyze Support first explained some extremely boneheaded stuff like how the feature is supposed to work and how to turn it on. Yes, Wyze Support. I know how to turn it on. It doesn’t work. Then Wyze Support explained to me that it was probably because I needed to update my firmware. Ok, Wyze Support, you’re telling me that all units sold had broken firmware, and you JUST fixed the bug in the past week. Seems unlikely, but I will humor you and update the firmware. Nope, didn’t work, so I wrote to support again. Now a new Wyze Support technician explains that I probably have the settings incorrect, so they give me detailed instructions for how to turn on the feature. No, Wyze Support, as I said the first time, I understand the settings, and I’ve done all the right stuff, and it doesn’t work. Oh, says the new Wyze Support technician, maybe you need to update your firmware. All this time, I’m keeping my cool and I’m repeatedly requesting them to answer one specific question: Does This Feature Actually Work? They will never answer it. They insist I should try a factory reset. I do the factory reset, followed by a firmware update. It still doesn’t work. I wait a couple weeks since I’m traveling. I write in again saying that the factory reset didn’t work. I get a response saying that my ticket has been closed. I open a new ticket, referencing the old ticket number, and say please don’t close my ticket as my issue is not fixed. They ask me if I have updated my firmware.

This kafkaesque song and dance continues for MONTHS. I point out that they managed to run out the clock on my 30 day return period and I think the product is defective and regret buying it. They offer me a Wyze credit so I can buy more Wyze cameras, in case I’ve absolutely lost my mind and want more of them. They close my ticket one more time. When I mention this, one agent I talk to says, and I quote, “we don’t close tickets” so I am forced to provide the two previous unsolved ticket numbers that have been closed in order to waste my time.

To discover that it is KNOWN that this feature does not work at all when the doorbell is installed in a battery-supported configuration is absolutely maddening. I could have returned this immediately when I found out it didn’t fit my needs, but instead they wasted my time in order to avoid that. I don’t appreciate your ruse, Wyze.

Same issue, but with the V2 wired doorbell cam. I guess the feature simply doesn’t work. They could just acknowledge the fact, or disable the feature and be done with it.

Oh well, I get a bunch of alerts, but overall, it is working as I expected, except for the zone feature.