Connect to Hikvision NVR

Now with RTSP available, has anyone tried to connect to a Hikviosn NVR? I have been able to connect to Blue Iris. Any help would be great.

1 Like

Have you had any luck with this? I am trying to do the same

Not yet. I have emailed Wyze asking which port is used, and they have not replied about that yet.

I got it working. Went to web page for Hikvision nvr, Then went to Configuration- System- Camera Managment. I highlighten a camera and clicked Modify. I entered the ip address the Wyze RTSP page (on app) gives me (just the numerical address). Chose Custom Protocol. Then entered username and password. Set Adding Method as Manual. Inside Custom Protocol I set Protocol as RTSP, then Transfer Protocol - RTP Over RTSP, Port 554 and Stream Path /live

1 Like

Hope these images show up. Mine still says offline. Any ideas?


I only have the main stream. I have the sub stream unchecked


I also can’t get mine to work, if you can impart your wisdom I would appreciate it.

Update: I figured it out and it works now. Instead of using “/live” in the above example, I changed it to “live” and it worked.

It’s not as smooth as watching on the app, but it is sufficient. I’m not using the beta version (I think that addresses the choppy issue), but I am really happy to get this integrated. Well done, Wyze!

Update: It seems to only stay connected for a short while and then the connection is gone (although the Wyze cam through the app remains connected). The only way to re-connect is to change the login information, then back, and it re-connects.

I added the same settings are what have been posted here, but I can’t get any video to show up. I tried with and without the “/” for live and still nothing. I just get the “starting live view” but nothing happens.

Any ideas on what is the issue? I have the Cam v3 model with the latest RTSP firmware that was released this week.

Any progress on getting the v3 with RTSP to connect via iVMS?

I have several v2 RTSP cams connecting just fine, but the v3 RTSP just shows an “IP exception” error. I tried both /live and live.

I am wondering if it has something to do with audio on the v3?

No luck. I gave up on the camera and will look at a different camera.

Any luck.
I too have 2 v2’s working fine.
My v3 shows an error bitrate exceeded limit.

Any luck on this?

I read somewhere it may have something to do with the audio stream.

Did you happen to get the v3 RTSP working on a Hik DVR?