Cannot view playback on V2 and firmware is up to date

Cannot playback videos.
Received a message across the screen saying:

Viewing events is no longer supported in this version of the wye app. Please update the app to v2.28+ to continue.

I’m up to date in the app. This just started about half hour ago. Another v2 camera is operating fine and I can view playback.


Same issue here. My mom messaged me and she got the same error.

The same result for Wyze Cam v3 cameras that don’t have CamPlus.

1 Like

Confirm if you are trying to view EVENTS from the cloud or PLAYBACK from the uSD card?
If it is Cloud events, do you have CamPlus on the cameras affected?

1 Like

Same here. I don’t care about have more than 12 seconds. Heither the V2 or V3 cameras work!

1 Like

Also having this issue.

Cannot view recent events (on my iPhone) from today recording on the camera, despite having an up-to-date app. Events from this morning are still viewable. I have a standard Lite subscription (not CamPlus).

I rely on these events. Please advise on a suggested resolution.


1 Like

If you have no subscription service on your cams and want to record 12-sec cloud event videos, you need to add a Cam Plus Lite subscription to your account for whatever price your want including $0. Log into the Wyze Services website using the same email address you use for logging into the Wyze app. Add the Cam Plus Lite subscription to your account, enroll your cams using the Wyze app, then go into the cam’s Event settings and choose Recording Type “Video”. Then turn on Person Detection if you want and set notification types:

It’s from the USD card.

I have 2 cameras at front of my house. One is SD card and other is on cam plus. The SD card worked at 4:42 pm this aft and then the recording at 4:48 pm won’t play. The camera is still recording but the playback is gone.

The update to v2.28+ isn’t even available…

Everything is updated.

This must be a glitch with V2 cameras.

Today I also started getting the error “Please update app to v2.28+ to continue.”

I have Cam Plus for some camera and Cam Plus Lite turned on for the rest. From the Cam Plus Lite set up page in the Android Wyze app, I enabled person notification for some cameras. I have the latest beta app (, On the event recording for two cameras (I checked Pan v1 and Cam v3), detects motion and sound is on, but there is no recording type option.

1 Like

Please update app to v2.28+ to continue started today 7th March 2022 around 5 pm EST.

I’m having the same problem today. I had videos at 4:21 PM, but only stills as of 5:30 PM. I updated the app to v.2.28 and it still won’t do anything more than still pictures. When I logged into my account to try to reply to your post, it forced me to setup a new account. WTH is going on, Wyze People???


I have exactly the same problem

1 Like

MAK, please tell us the steps to accomplish this. I have gone into my Account > Services and Lite is not visible.

Sounds like you do not have Cam Plus or Cam Plus Lite. Please read this thread (or at least the beginning of it). This information has been very well distributed. In fact I just got yet another E-Mail about it a few minutes ago.


After applying for Lite, I had to restart each camera. Events are working now.

I have received NO notice about these changes at all until the issue started today and I came to this forum to see if anyone else was having the problem. Not communicating something this important is a poor practice for such a great company and team.

1 Like

Actually, it doesn’t have anything to do with the length of recording time. The camera is on an SD card and totally updated. The other V2 camera I have is on CamPlus and working fine.

My reply was not to you, it was to user “your-name-here” who has cams with no subscriptions.

If you haven’t updated your app, you will encounter odd results. If you are unable to see the latest app update, give it time. Google is sometimes slow to push out updates from some regional servers.

(post deleted by author)