Can someone help me with a Wyze + Echo Show routine to mute audio?

I’ve never really messed with Routines before. What I want to do is set it so every time we open the camera it mutes the audio automatically. The camera is technically in the same room as the Echo (facing out the window) so we get horrible feedback whenever there’s a noise. What would I need to do for that to work?

This isn’t possible as far as I can tell.

Welcome to the forum @shieldstas
I don’t know if you want sound on your camera since it is in the house. But, you could simply just mute the camera from the Wyze app. When you mute the sound from inside the Wyze app it will also mute the sound on the Echo device.

I tested the following routine, and it worked once, then my Echo devices starting acting up. My guess it is using the same command to pull up the camera, then trying to set the volume to 0 and got confused.


but even with this your echo device would remain muted.

You may be able to to write a routine that has two commands, set Echo Volume to 0 and show the camera, Like if you say Alexa, I want to see outside and the internal routine is set volume to 0 and show me the (CameraName) I will dig a little more when I have some free time.
Then you would need to turn the volume back up again.

2 Likes

You can setup a routine in alexa to do everything you want. When you set your actions go to device settings and you can mute or set the volume level to one or all of you Echo devices. Then, the very last action needs to be a voice command to the proper Echo device to show the camera.

Putting together some screenshots.

Last command is “Custom “

2 Likes

Some nice answers above. But when in doubt there’s always surgery…

Yes, but the question was for an Alexa routine solution…

:blush:

This routine sorta worked.

It set the volume to zero or muted the device but because the echo device wanted to respond to the command it turned the audio back on or up to about 5% to say “OK”

I even have the responses turned off. FYI this was on an echo show 15

Hmmm maybe if I flip the commands…

Nope, it won’t allow me to ask to show the camera first

1 Like

After doing some reading, I don’t think you need the Stop Audio command. Try it without.

2 Likes

I tried with and without, but built a new one to test. It did the same thing, you see volume go to 0 then back up for the response to calling up the camera.

1 Like

Yes but there is little if any reason to have this particular camera audio enabled at all. It’s recording outside (through a windows). Locally it is redundant (and causes feedback). Remotely it would only allow room audio while the picture shows outside - mostly useless.

If the mic and/or speaker were permanently disabled the poster would not have to mess with any routines.

Of course there’s always moving it outside the window. :slight_smile: