Camera keeps going offline

All of the sudden my 2 Wyze Cams (v2) are either not connecting or say ‘device is offline.’
This started happening today but the cameras were working this morning.
Yesterday, I had to cut the shared circuit to replace an outlet . Also, had to turn off the router yesterday as well.
Today, my phone had trouble connecting to my usual 2.4g network (the network the cameras are on). Eventually, was able to connect but am thinking it’s related.

Just power cycled both cameras. Still won’t work.

Both my cameras show ‘Device is offline (error code 90)’ but they were working an hour ago

Power cycled mine as well and rebooted my phone. Still doesn’t work

I occasionally get that on one or more of my cameras following a WiFi or Network outage. It usually takes the following sequence to restore everything to full functionality.

Turn off/Power off the following devices. No particular order so long as they all end up off. Your mix may vary.

Access Points

Turn back on in order.

  1. Modem - wait for it to boot and fully connect
  2. Router. Wait for it to fully boot.
  3. WiFi extenders
  4. Hubs
  5. Access Points - wait until fully powered up
  6. Cameras

I’ve also been experiencing this problem with my 3 cameras in the last 2 weeks. All three of my cameras was offline 5 minutes ago for the past 2 hours and as I’m typing this message now - it seems that 2 of them just came back on.

1 of 3 of my cameras is solely using the original cable and adapter plugged directly into a wall outlet. 2 of 3 are the same except plugged into an extension cord as the outlet is too far away.

The last time this has happened was only 2 days ago. Already went about power cycling and rebooting the routers.

Have only experienced this after updating to the latest firmware, my set up’s details are as follows:

  • iPhone XR / iOS v13.3.1
  • Wyze App v2.8.20
  • Firmware v

Appreciate any insight on this matter, thanks!

I hope I have finally solved my issue of either not being able to connect one or both of my Wyze cams or having them constantly showing offline. I finally found helpful advice (sorry I don’t have a link but google it) and in the last week I connect to both cameras every time without fail. That has never happened before. I changed two things. I have an ASUS router and by googling that and Wyze can I found that (a) I should NOT have the same PW for the router 2.4 and 5 ghz settings and (b) I needed to go into router settings and turn OFF something called airtime fairness. I did both those things and it’s been smooth sailing since then. Only been a week but they work better than they ever have. Hope this helps someone.

1 Like

Jan. 4, 2021
I have just installed 5 brand new Wyze Cam 2, two from Home Depot that came with Wyze 32 gig SD cards, 3 purchased from Amazon and I installed San Disk 32 Gig microSDHC UHS-1. 130MB/S speeds A1 App performance Perct for recording Full HD Videos. All 5 cameras MicroSD cards have been formatted in camera. All cameras have been updated to the latest firmware

All cameras are powered from the Original Wyze cables and power pack. My home has good 120VAC commercial power.

All cameras are within 20 feet of a high-end newer model ASUS 4 antenna Wi-Fi router connected to high-speed internet.

All cameras are getting strong signal. 3 bars displayed on about cameras.

All cameras have been power cycled.

Randomly I will find several cameras offline, it does not appear to be any particular camera, they all have gone offline at some point. clicking on the cameras they will seem to work again as if being woke up.

I have seen it mentioned here that this can happen with cheap USB cables and power adapters. These are all brand new Wyze cables and adapters. Does this mean all my new cameras are defective and should be returned?

Are there setting in my router I should look at?
I am a network engineer/telecom engineer and will understand more technical things on Wi-Fi router settings so don’t be afraid you will be talking over my head. I can work with you troubleshooting. Thanks.

Please advise.

See my 2 posts and video with voltage drop testing with the V3 camera and USB extension cords .[](

I also had lockup issues getting video data 3/3 , accessing the SD card and when I used the siren it would lock up and need to be power cycled .
I replaced 2 V2 cameras I had outside with 2 new V3s using the standard Wyze power brick and 15 - 20 ft of USB extension cord . I found a lot of issues with voltage drop across the USB extensions and the used original 6ft Wyze power cord .
I have done extensive voltage drop testing on the bench and have documented in a series of Videos below
I also found some of my original V2 power bricks powering a V3 at 340 ma and the Wyze 6ft cord the power brick was only supplying 4.75 volts .
The V3 is extremely sensitive to low voltage

Gee, I don’t think I should have to buy 5 new bricks for brand new cameras not even 5 days old out of box. Is Wyze supplying better USB power plugs for new cameras with these issues?

Have you tested the cameras without the SD cards? Also check for an Asus router firmware update.

I just installed Wyze cam few days ago. It was working fine and then this morning it went offline. The internet is working but the camera is no longer connected. I have SD card and internet is working fine, please advice.

I have a Wyze Cam v3 that keeps going offline lately, but no such an issue with v2.

1 Like

I too am having this issue.
I have created a ticket. And received emails. But do not know how to reply back to support. I am stumped what to do.

Just a reminder, make sure you have the latest V3 firmware. One of the firmware updates is supposed to help with connection issues. Go to Account->Firmware update.

I have 3 cameras that keep dropping off the network. This didn’t happen until I got the latest SW update. To reconnect, i disconnect power. It lasts for a day. The next day they all report offline. They are all on separate, original Wyse power sources.

Very frustrating… was working for more than 6 months… but the latest updates killed the reliability.

Any way to roll these back to an older SW version?

Have you rebooted your modem+router since the firmware upgrade?

I found that sometimes doing this helps.

Yes. I’ve systematically rebooted everything several times. I’ve isolated it down to the cameras. It is most definitely the sw update that is common on all 3 cameras. The system was stable for a long time. The router sw hasn’t had an update… so it hasn’t changed. Other things are working of that router. It is just the cameras.

I assume you have V3s, because that’s the firmware they pushed last.

I have V3s and I don’t have that problem. Maybe your V3s have different revision boards and Wyze didn’t test?

But mention your ISP and router model if you know, just in case someone here has the same set up.

You can always flash the older firmware. Search these forums, there’s a Wyze firmware download page and the instructions. You’ll need a 32gb micro SD card.