Cam plus won’t activate on v3

I have every wyze cam available and can get my cam plus to activate on any of them except my v3 cams. They are there showing but when I select the box and click activate it takes me back to the previous screen showing I have 1 cam plus subscription available. I can make the cam plus subscription work on any other cam just not either of my v3 cams. Please help. My free trial on the v3 cams just ended a couple of hours ago so maybe this has something to do with it?


Well thanks for the help everyone, lol
I did figure this out. My free cam plus had ended yesterday at 4pm and around 6pm I was trying to add my cam plus annual membership to that camera. The free cam plus had ended and I was only getting clips every 5 min but the app still showed cam plus as active in some places but not others. Once the app had fully recognized cam plus was no longer active I was then able to add cam plus to the v3. The cam plus stopped around 4pm and I was finally able to activate cam plus at 10:30pm. The last I had tried adding it was 7pm and at that time it still would not activate so not exactly sure how long the app took to completely recognize cam plus free trial was over. Why it doesn’t recognize this as soon as the cam stops recording all events I have no idea. What sucks is this went down to 5 min 12 sec increments during a serious incident happening next door. At about 5pm fire trucks, paramedics, and police all started rolling in and I missed most of the situation.

It usually takes a little bit for the system to catch up and for the trial cams to show back up once the trial expires if the cams are on the trial at expire tine. You can always remove your cam trial before it expires, or opt out of the trial offering.

But you did get the cams over to the regular subscriptions?

I ordered the v3 and prepaid for 1 year of Cam Plus. It will not activate. Under services it does not show Cam Plus. What am I missing?

Did you use the same email during the purchase as the one associated with your Wyze account? If you log into the services website (not app), what does it show?

I have the same issue. I set up my V3 today and I also paid for 1 year. I went to service on the site and it states I only have 4 (which are for the outdoor cams) The one for the V3 is not listed? The app shows 14 day free trial expires 2/16/20.

For the cam plus to show when I bought my v3 with 1 year it took 7 days after purchase for it to show in my app I emailed tech support and that was what they told me aswell. On day 7 it was in my app to apply. I added it to my pancam and worked fun until I received my v3 my v3 trial just ended and I’m having the same issue where I can’t apply cam plus so I will wait longer and see what happens.

When my v3 trial ended it wouldn’t take the cam plus subscription for the first 6 hours or so. Then all the sudden it was able to accept cam plus. So I think it just takes a few hours for the app to fully realize the free trial has ended.

yeah appears the trial over writes it so it has to fully fall off then you can freely swap after a grace period… i got a hold of support guy was very helpful and explained it. thx for reply just noticed i had a reply.

It’s best to remove the trial before expires or not do the trial so that the paid for camplus subs are available right away if that’s your flavor. I’d you leave the trial on it’ll take a day or so to have the system catch up and release the camera.