Amazon Fire tablet can not access 1 of 12 cameras?

This is a little odd, at least to me? I have 12 cameras, V2, V3, WOC and Pans. On one of my Pans, I get the following when I try to access the camera on my Amazon Fire Tablet:
“Connection failed” Please try: 1. Force close app and retry 2. power cycle the camera.
The tablet can access the other 11 cameras without incident. I can access all 12 cams, including the Pan on my Samsung Note 10, my Iphone Xr and my iPad and even on my PC using BlueStacks??? Any thoughts? Not a real big deal, but I do use that Fire tablet as a fulltime camera monitor.

Same state after you power cycle the cam?

What firmware version is on the camera and what app version is on the Amazon tablet? When did you last update those?

1 Like


firmware App - 2.18.18

Shows all firmware up to date and has same version as my other Pan. I update all the time, one of those crazies that rolls the dice on app and firmware updates.

Unreal!! Now that I have been playing with it, all V2 and Pans are displaying that behavior while the V3 and WOC are fine??? I pretty much just monitor the V3s real-time, so will wait and see if an update or time shakes things out??? Amazon updates are always behind it seems, so maybe something coming in near future??

Is there a Wyze app on fire tablets? Isn’t that tinycam?

I believe there is a tinycam beta that fixes that problem.

I had completely forgotten that Amazon does not have the Wyze app available for Fire and that I had side loaded it!! Probably going to have to find a more current APK file and reinstall it. Sorry for the bother, damn memory not what it used to be.

1 Like

What Android version is on the Fire? Mine only goes up to Android 5 something.
All device OS versions lower than Android 7.0 will not be compatible for 2.22+.
/edit - My Fire was my monitor also :frowning:

That could be it. They actually run Fire OS and not android proper so those changes taking out the old android versions most likely are the issue. Have not tried looking for a newer APK but may not make a difference anyway.

Are you using the Alexa Device dashboard?

I have noticed intermittent issues as well from time to time and generally it is on the Amazon side. Like the V3s support live view now but if you add a new V3 it takes a day or two for live view to be available.

For your Pan Cam… what has worked for me in the past is to remove the device from Alexa and let Alexa rediscover the device.

Amazon is also always making updates to their Device Dashboard behind the scenes and I have cleared all devices a time or two now just to refresh, a pain if you have a lot of routines but, IoT and automation are still pretty young and maturing sometimes it helps to flush.

OK. So I downloaded an updated APK file and swapped them out. The Fire can now access all cameras, any version, without difficulty. Thanks for the reminder on version issues, appreciate everyone’s help.

1 Like