Alexa Routine triggered by Wyze Lock stopped working

I have been using Alexa routines to do a few things when my Wyze Lock either unlocks or locks. Everything was working great until today. The routines that have a trigger of the lock unlocking or locking no longer fire.

I am able to control the lock via Alexa to lock it. I did turn on the app unlock and voice unlock, and was able to control the lock that way as well.

I have not unlinked and relinked Wyze to Alexa as I am trying to avoid having to set up other routines.

1 Like

Mine is also no longer working. I tried uninstall/reinstall on Wyze app and deleted all Alexa routines as well as deleted it out of Alexa devices. Nothing has worked. I have full control from the Alexa app but no routine… very frustrating.

Interesting. I have some routines that SHOULD announce motion detection to several Alexa Echo devices but they’ve stopped working recently as well. Nothing changed on my end to cause the failure. Guess I’ll try relinking the Wyze account.

I have resorted to a mess of IFTTT and Wyze rules to make things happen.

Wyze rule: when lock unlocks turns on a wyze plug
IFTTT: when plug turns on trigger a rule in Hubitat

My lock is also not triggering Alexa routines. It worked fine for several months but over the last 2 to 3 weeks it doesn’t work

Same here. The Alexa routine stopped working on April 9th. Trying an alternate route with IFTTT. Will post it if it works.

I also have experienced this problem.
I tried removing the Wyze Lock from Alexa devices and letting Alexa re-find it, which succeeded, but still no Wyze Lock actions trigger Alexa routines as they used to. Also, Alexa is no longer able to trigger the Lock to unlock; instead, it says “Lock doesn’t support that.” Obviously it used to support this.

When you had Alexa rediscover the lock did you also go in an turn on the unlock features? When I added my locks to Alexa if I wanted to use the Alexa app or voice to unlock I had to specifically turn that on.

Yes, I did. Also, the unlock button presented in Alexa gets stuck on “Waiting for Wyze…” and then times out; but the lock usually does open. The voice-command unlock doesn’t work at all, as I noted above.

Having issues lately also. Removed, readded, both gateway and lock. Disable/enable skill, changed networks, changed gateway location, removed from alexa, checked firmware. Have tried everything. It “appears” like alexa is not getting responses back from the lock.

Support NEEDS to address this. I haven’t bothered there as in the past it’s been back and forth email that gets nowhere in the end.

You’re absolutely right.I think I have five open tickets right now. Nothing ever gets done and the back and forth is absolutely ridiculous. I will put a ticket in for this and see if we can get somebody to at least look at it. Honestly it’s the reason why I haven’t moved ahead on the home monitoring system. These things are good for standalone products but integration and customer support is severely lacking

Problems have progressively gotten worse. It started with Alexa only unlocking my doors 75% of the time and I have now dropped down to 100% fail.
Alexa can still lock my locks by voice or routine but can no longer unlock. When you open the lock in the Alexa app, the “waiting for Wyze” loaded fairly quickly. Now I get a never ending “waiting for Wyze”.

I have spent hours on the phone and chat with both Wyze and Amazon. I also put in a ticket with both.

Some sort of update would be fantastic!

Yes, I have not found a fix. It really seems to me there is a breakdown in Alexa processing a response from the lock. The wyze app is receiving the responses back but Alexa seems to not receive the status responses or fails to process them. There are several threads on this same issue, all with the same problem and none with a resolution yet.

1 Like

Agreed; I am having the same issue - “lock is not responding” even though Alexa is able to lock/unlock. I made a post to the Wyze Core Group in Facebook and tagged @WyzeGwendolyn to hopefully get a response and some guidance on this on-going issue.