Alexa Echo Show can’t find new Pan cam v3

I recently added a wyze pan cam version three to my Wyze account. I have several pan cam twos and they all are working fine with my echo show. But my Alexa hasn’t been able to find my new camera. It was added to the account. I’ve tried disabling, and re-enabling the Wyze skill and rebooting both the echo device and the camera. None of this has worked and it’s been a few hours since I first set up the cam. Any advice?

Welcome to the forum @dmabe100!

Alexa can be quite finicky at times as I have learned over the years. A couple of suggestions you could try if you haven’t already.

  1. Try the command Alexa, Discover Devices. This will force a device discovery since it was not auto discovered.

  2. Try renaming the camera in the Wyze App, some time this “gooses” Alexa because the new name looks like a new device.

1 Like

Welcome to the Wyze User Community Forum @dmabe100! :raising_hand_man:

I have 4 PanV3 Cams that auto detected to Alexa right after install. But, I only use the Alexa App. Are they also not showing up in the Alexa Phone App?

1 Like

It is also not showing in the Alexa App

1 Like

Your advice helped. I had previously run discovery, and it didn’t find it but I changed the name and then ran discovery, and it found it. Thank you very much.


Excellent. Appreciate you letting us know.

1 Like