2.19 RC App Testing 3/30/2021

  • iOS: 2.19.16 (3)

  • Android: 2.19.12

  • Improved the installation tutorial for Wyze Video Doorbell

  • Fixed incorrect personal information for Wyze Watch 47mm

  • Fixed a bug that prevented Wyze Cam Outdoor’s Base Station from connecting to WiFi if the SSID has a special character (iOS only)


Installation was fine. No issues and all camera’s are working fine. Will check to see if there are any issues.

After installation, App refused to load twice, third attempt it loaded, but was frozen on the home screen. 4th attempt it was totally fine. Could’ve been a fluke. Never happened to me before on any other app, including Wyze, so I thought I should report it just in case it’s not an isolated event.
Google Pixel 5 with Android 11

When I went to events and clicked “person” to filter to only have person events, it filtered out EVERYTHING and said there were 0 events (I have a ton of cameras with tons of events though). I deselected the filter and re-selected it again and it worked properly this time.

TAGGING for video submissions is restored now! I was able to submit an incorrect “Person” event of just my black cat, and tag it correctly as “Pet” and submit fine.

Hopefully those weird abnormal bugs I experienced don’t persist. I will update again if they do.

1 Like

This is good news on the tagging. Just confirmed I have it as well. Did not have any of the other bugs you reported.

I should clarify that when I told google play to update the app, the Wyze app was already open. However, usually Android will download the update, then close the app, then install the update, then usually, but not always, reload the app after installation completes. In this case, I don’t think it did that. After installation was complete I saw the Wyze app was still open on the exact screen where I left it, indicating it never closed out then reloaded as most apps do. It’s like the installation took place while the app was running. Not impossible, just very abnormal. So I closed the app then tried to reopen it again, and that’s where that initial post picks up…didn’t load, didn’t load, loaded but was frozen., then loaded and worked fine, and has worked fine on subsequent attempts so far. Still, very weird abnormalities that may not be Wyze’s fault at all, but that they may need to be aware of nonetheless.

1 Like

Similar problem launching 2.19.16 (3) on iOS. Splash screen then crash. iOS asked me to submit a crash report. Also filed one through TestFlight.

After three crashes, it loaded on iOS 14.4.2 (latest/greatest).

1 Like

Great update. My watch now syncs my sleep data to Google fit. It didn’t before

Interesting! Nearly exactly the same thing for us both, but this time on iOS. I’m glad to hear this (not glad it’s crashing, but glad you posted about it and indicating it’s likely not a coincidence). This indicates there may actually be a bug in the shared code somewhere…I mean, 3 crashes in a row then working fine for both of us? I mean, I’m glad it’s working fine after 3 crashes, but it’s just really weird that it went through that same loading sequence. Thanks for sharing

I still got an in app push notification for a deal even though I had it turned off in the in app notifications section for new products and deals. Ticket 177450.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.