WyzeCam "eating" micro SD cards?

I have several WyzeCam products, both WyzeCam V2, and Pan Cams… my issue has to do with micro SD cards/local recording. Both my WyzeCam V2s (4 of them), and Pan Cams (3 of them) seem to “eat” micro SD cards. To explain, I insert/format brand new micro SD cards, and within two weeks, the micro SD cards no longer function. The app states “No SD card installed”, when the card is indeed installed… so there is no option to format the card that is in the camera(s). Removing the cards and attempting to format them in Windows 10 results in the micro SD cards not showing up, or if they do, I’m prompted to “scan and repair” the cards… all attempts to repair the micro SD cards fail. I have purchased multiple brand new micro SD cards, inserted/formatted them in the cameras, and within a couple of weeks, the micro SD cards no longer function, and are not repairable. So far, I have gone through a total of 14 micro SD cards, and it always ends the same… the cards work for local recording for about 2 weeks, the abruptly fail, and are not repairable.

Is there are reason this is happening? Is there any way to repair it? I am exasperated with having to repeatedly spend money on micro SD cards, only to have them fail shortly after installing them in the cameras.


Can you say exactly which mSD cards you are using. You should, at a minimum, be using Class 10 cards. Even better, you may want to try using cards labeled high endurance.

1 Like

I just had the same problem. Just got my pan cam yesterday. Set it up. all was good. but this morning, I cannot use playback any longer because it says there is no SD card installed. It worked fine on playback yesterday, and today nothing. I have tried taking out the card and reinstalling it, and have tried restarting the camera.

Still it does not recognize that there is a card installed.


1 Like

What brand/model/sizes have you tried so far?

SanDisc 30gb

1 Like
***Can you say exactly which mSD cards you are using. You should, at a minimum, be using Class 10 cards. Even better, you may want to try using cards labeled high endurance.***
Every MicroSD card I've used so far has been class 10 or better. To date I've used Sandisk, PNY, and Patriot brands. I've tried both 16gb & 32gb, and have also tried both the standard and "high endurance"....... results are ALWAYS the same.... within about two weeks, the card is no longer recognized by the camera(s), will not show up in any device it's inserted in, and the card is unrepairable.

I’ve had a number of frustrations with WyzeCam products, and I suppose this is just another to add to the list. I sent in a support request several days before I posted here…but as usual, got no response. If WyzeCam holds to the pattern, they’ll contact me, now that it’s on the public forums…and give the excuse that they never received the support request. (That’s what always happens when I sent a support request).

1 Like

Happened to me 3-4 times already with 32gb sd cards.

It brakes the cards and they cannot be erased or formatted anymore.

This needs a solution ASAP.

I’m a bit disappointed now in these cameras. I needed to see if my neighbor’s dog was what came into my yard earlier this evening and attacked a cat that I feed. When I went to View Playback, there was nothing at all on the card. Ok, I thought, I have another camera that would catch the same area in the yard. Nope. SD card full and nothing at all on it to see either. I thought this camera was supposed to fill the card and then start writing over prior days with new video? I don’t want to pick thru all the video clips on the cloud hoping to see what happened but now I’ll have to.

I read a few comments that others were having problems with the card filling up and not recording anymore so I tried to reformat the card in the camera using the format option in the app. It failed to reformat and now it’s not recognized at all. It says there’s no card even in the camera and to install one and turn on local recording option. When I go to that setting, it says that there’s a card available and it’s set to record events. There’s still no room on the card because it didn’t reformat, but it sees it.

Now all it does is let me use Live Stream and it has an irritating click every few seconds if I have the volume on–like a record spinning around and around with the needle stuck. And stupid me. I thought it might be a bad card so I tried reformatting the card in the other full camera. It also said “reformat failed” and now it’s not recognizing that card either and has the same irritating click when I have the sound on in Live Stream. It must be trying over and over to read the card. That can’t be good. I restarted both devices and that didn’t help.

I guess the cameras ate my cards like they did EdCaffreyMS’s. And yes, even though I bought a couple of different brands of cards that weren’t really expensive, I did buy the recommended size and type of SD cards. And they used to work great–until they filled up. Now they’re not even recognized and I can’t reformat them using the app. I’ll have to get the ladder out and see if I can reformat them in my computer. I doubt it from what others have said. They may be garbage now.

I was so excited about the great price and the great quality of picture on these cameras. I told a bunch of my co-workers about how good they were. I had 10 Foscams but a few needed to be replaced and I didn’t want to spend that much money per camera.

I’ve bought 4 Cams, 3 Pan Cams, outside mounts and covers for all of them, about 10 different length cables and SD cards for all of them. And they didn’t work when I really need them to. I need two more to fully cover all the areas around my property but I don’t think I’ll get them until they’re dependable. It’s a shame. I was so pleased with these before.

I can’t afford to replace these cards all the time. I don’t know how to scan and repair and reformat these cards like some people suggest. And some say they’re unformattable when this has happened. I have no idea what FAT32 is. I just want to plug the card in and have it work like it’s supposed to. And I don’t want to be dragging the ladder all around the house every other day having to replace the cards.

Any suggestions? I don’t see anything in the forums that this has been solved but maybe someone has had this issue and figured out a solution? Let me guess–Wyze’s cards are the only ones that will work properly at $14.00-$20.00 each? :slight_smile: :cry:

Thanks for any ideas.

Similar experience. I used a class 10 card (exactly like the one recommended). Same results as OP. On a side note, I have a 64 GB card in a second camera (Ver 2) that has worked since the version 2 cams came out. Go figure. I replaced the bad card in the ver 1 camera. If the replacement goes bad too, I’m out. Can’t keep throwing money at new cards.

1 Like

I have also experienced issues with the camera’s and recording onto SD cards. I can usually find a way to get the cards reformatted but when they get down to about .7GB or less the camera performs very poorly (sporadic viewing of the live stream, can’t view playback, Authentication frequently times out, Camera doesn’t respond to any App commands). Once I remove the SD card that is full all these functionalities, excluding the playback, come back to life and perform as expected. Once I get the card formatted, either in the camera or remotely and re-insert, the camera performs well until the card fills. I have found this takes about 4-5 days when set on continuous recording using 32GB card purchased with the camera. Work Around I am trying switching the camera to ‘Record On Events only’ and that seems to improve the performance all around. One more Note when I pull the SD and go to view the data there is a chunk of space consumed by files in a log folder, in some cases over a GB.

1 Like

@MarsLikeThePlanet can we replace OP’s camera and try see if we can reproduce the issue in our office ?

Absolutely! @EdCaffreyMS would you mind sending me your ticket number in a private message? I can’t seem to find your ticket but I’d be more than happy to help out :slight_smile:

You folks are predictable if nothing else… “I sent in a support request several days before I posted here…but as usual, got no response. If WyzeCam holds to the pattern, they’ll contact me, now that it’s on the public forums…and give the excuse that they never received the support request. (That’s what always happens when I sent a support request).” I no longer have the ticket number… it went in the trash after a week of you not responding. I started the tread 21 Oct… and just now getting attention?

The idea of replacing my cameras would mean sending me 5 Wyzecam V2, and 3 PanCams… ALL of them have destroyed the SD cards I’ve installed in them. As of right now, 5 of the 8 deployed cameras have destroyed the installed cards… again. I’ve simply given up on spending money every 2-3 week for micro SD cards… the cameras are live view only.


WyzeMars isn’t in today but if you don’t have the support ticket number, sending the email address that you used to generate it should do the trick! :slight_smile:

We apologize for the issues that you’ve had with our support. I’m going to tag @MarsLikeThePlanet in this to make sure that they see your comment about this not being the first time we haven’t been able to find your ticket. Sounds like we need to look into what’s going on from our end to see if there’s something funky going on with ticket submission or responses.

Ive been using U1 or U3 class cards with no issue. You may want to try a U1 class 10 card.

All I know are the my previous experiences with support. It’s a pretty obvious pattern, that has occurred since my very first support request…
I send in a support request, wait (usually a week or more), don’t get a response, and then come to the forums and post the problem/issue here. Then within a day or two of posting it on the forums, an admin jumps on the thread asking for the support ticket number, and claiming they couldn’t/can’t find it. With all due respect, I think it’s simply a lack of caring… don’t pay attention to support requests, and most of them will just go away.

Hi @EdCaffreyMS I sent you a private message :slight_smile:
As soon as we can help resolve your issue, I’d love to look into why your support tickets aren’t coming in! Feel free to message me with any questions you have! You can consider me to be your personal Wyze Wizard :slight_smile:


We definitely care! And we’re trying to get to everyone. We’re sorry that this has been your experience. I know that WyzeMars is looking into this issue now.

1 Like

I replied to your PM

1 Like

Same this happened to me on 11/24. Installed 2 new Wyze Cams. On one, the SD card would work an hour or so, and then say no SD card installed. I’d pull it out, and reinsert. Then maybe it would work another hour or so. Pulled a new SD card out of a pack, and seems to be working for now. Definitely some kind of issue with the HW or SW.

1 Like