Wyze Watch 47 Button Issues


The button stopped working on my Wyze Watch 47. Restarting the watch did not fix the issue. Anyone have any ideas as to what the problem might be?


1 Like

My side button has never worked.

On my Wyze Watch 47 the side button gets stuck pressed sometimes and I have to use tweezers to extend it again, it’s a recurring issue with mine but my wife hasn’t had any issue with hers.

Welcome Eric. Please give Wyze customer service a call and explain the problem with your watch and they’ll take care of you:

Wyze Customer Support: (206) 339-9646
Available Monday - Friday 5 am - 6 pm PT
Saturday 8 am - 4 pm PT

My wyze 47 does the same, a lot.
Sometimes for days.
The tweezers are a good suggestion.
Has anyone tried oil or lubrication?
I am afraid that might negatively effect water resistance.

Was anyone ever able to figure out a solution to this? My button somehow won’t depress and so I can’t use it. I tried tweezers, but don’t seem to be able to get it to come out far enough to be pressed.

I found a rather simple solution, I run it under tap water and press it a couple of times and then it works again.

I know I am late to the party on this but I had all but given up on my watch till I tried the running it under water suggestion thinking what do I have to lose at it was not working with anything else and holy moly it worked,