Wyze thermostat screwing up Brand New Furnace!

After many problems with my 33-year-old gas furnace, I finally had a brand-new furnace installed today.

Unfortunately, my Wyze Thermostat is already giving me headaches! After running my heat and the furnace shuts off, it comes back on again 2 minutes later and runs again! The burner and the blower are both coming on the second time around. Note: I have the fan activation delay set by furnace.

This is similar to the problem I had with my old furnace, Well, I decided to disconnect the green wire in my Wyze, but this didn’t help. In fact, the furnace ran 16 minutes to raise the temperature from 66 to 67 degrees.

Attached is a photo of the wiring in my new (Carrier) furnace. The installer attached the wires. I didn’t touch the wires in the thermostat; I left them the way they were with my old furnace. Note the double wires going to 2 screws. Note, also, the 2-wire sub-block below the other one.

Can anybody explain this to me?

If you had a new Carrier furnace installed today, shouldn’t the installer make sure the furnace is operating properly?

If you have to troubleshoot it, I would try an old school Honeywell thermostat to see if it improves the furnace operation.

Well, the installer had me turn up the thermostat, and the furnace fired up and heat was coming out of the vents, so he figured it was working and left.

I still have my old-school Honeywell thermostat, but all that will do is turn the furnace on and off. It won’t duplicate the features of my Wyze.

That’s the model of the furnace? I’m not familiar with this board layout, what is the connector labeled P5B?


I have a 32 year old Janitrol gas furnace. It was acting weird during heating cycle shutdowns. A new old school Honeywell fixed it for me. I was thinking if you tried the Honeywell on your new Carrier you might be able to isolate if your issue is with the new Carrier or the Wyze thermostat. Probably best to call the installer back.

Sorry. I’m not an HVAC expert. I don’t know what P5B is.

OK, I think I have the problem solved. The installer came by today, and found that a hose coming from the furnace’s pressure valve was disconnected. Probably happened during installation. Well, it’s been several hours since he left, and the furnace appears to be working properly. So it probably wasn’t a problem with the thermostat at all.