Wyze Thermostat Black Screen - Wiring Troubleshooting

Hello, I have followed the install instruction on the application. The Wyze thermostat is working fine through the application and controlling the system. The screen on the thermostat does not function or turn on at all. Here are the pre-wiring pics:

Post wiring pics:

I have an unused blue wire between the thermostat and control board. Should I use that for the C and not use the extra Controller? Or do I need to hook the extra yellow on the control board before the controller as well?Thanks.

yes you can link your used wire on C terminal of the control board and the thermostat, then install again, tell the app you have new C wire. However, our C -wire adapter is basically doing the same thing…I would suggest to using the C-wire adapter.

1 Like

Okay, I would rather use the Wyze adapter. Am I missing a step or connection to get the Wyze thermostat screen to turn on? The backlight turns on when I touch it or get close, but nothing shows up on the screen. It is controlling the system fine through the app.

I attempted a fix: deleted the Wyze C adapter and wired the control board back how it was. I used the blue wire that was not used on the control board at C. At the Wyze thermostat I moved the green wire from C to G and the new blue wire to C. Turned the system on and the AC and furnace turned on together.

Still a black screen on the Wyze thermostat both ways. I can still control the Wyze thermostat through the app, but nothing has shown on the screen.

Did I miss a step with not uninstalling the thermostat from the app and reinstalling it? The screen still was black.

Any help please and thank you!

Now I tried to redo the whole install. I deleted the Wyze thermostat from the app, I am trying to add it again and the Bluetooth isn’t connecting. I don’t think the factory reset is working. Holding the button down for 10 seconds. I have tried every way to do this and it is not working.

This is sounds a defective unit if you can control it in the app, but not on the thermostat. @Chuan do you agree? Try holding the button down for ten seconds to factory reset and see if you can get it back in the app. If you can, check to see if you can update the firmware. If you can’t You may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT
Or online: Wyze.com/support
phone support is typically faster however this isn’t always true due to fluctuation in the amount of calls. Support will also be off for the holidays, so plan accordingly.

It did let me install the updated firmware when I originally installed it. However now the factory reset does not work at all. The screen remains black and I had to revert back to the old thermostat to get heat to work tonight, since it won’t let me add the Wyze thermostat to the Wyze app without the factory reset.

I’d contact support with the above information. You may need to wait a bit if you can’t call tonight because they’re off for the rest of this week and next week for the holidays.

Thank you!

I have a similar to this issue with my Wyze thermostat. I was wondering if you were able to fix the issue, and if so, what did you do for that?

I had a defective unit and had to send it back to Wyze and they shipped me a new one and it worked perfect.

1 Like

Thank you, troydebie, I contacted the support and they also suggested that my unit is defective and will be sending me a replacement.