Wyze switch does not respond to first click/press after being unused for a while

Hello! I am having trouble with multiple Wyze switches in my home. When they have been untouched for a while (say 30 minutes or more), the first single press does not initiate the correct action (which would be smartly/remotely turning on or off a Wyze bulb). If I wait a few seconds and try again, then it is as if the switch “wakes up” and does perform the correct action. It is as if the switch is in standby or sleep mode, is that possible?

Double/triple clicks and press-and-hold functions work properly, no issues, but the first single press does not always register.

It drives me crazy to walk into a room, firmly press the switch, and just not receive a response (it isn’t delayed, the action is just not performed). I end up needing to go back to the switch a second time to press it again; the second press works as intended immediately.

Has anyone else noticed this issue? Is there something I am doing wrong, or a setting i can adjust? Is this a known issue? Thanks for any help in advance!

It sounds like when you press the button it’s turning it off and on…

How is the single press set to ?

1 Like

I have the single press set to smart control, see the image below for an example.

If I set my switches to classic, they work as intended (no delay or unresponsiveness). However, I would really like to use the additional features that double/triple/press-and-hold provide.

It seems like there is either a bit of a bug, or maybe a feature/setting I am not aware of.

1 Like

I did experience this issue but, it only happened few times since I have the switch installed.
It always fixed itself after one or two additional presses.

I always considered the issue to be communication related.

Did you try to shut this circuit off for few seconds?
Also, there is a factory reset. You could consider doing it and attach it again to your setup.
Wyze Switch Reset

1 Like

Hi @realdiels

I just tried this and it worked. I set the single press to Smart Control and selected a wyze bulb in my lamp in my living room.

When I pressed the switch button physically and turned it on/off on the app, both turned the bulb on and off.

Not sure what’s causing your switch to not turn on and off a bulb , have you tried removing the bulb and then adding it back again and seeing if that fixes it ?

I’m not too shabby with the wyze switch and I don’t have any rules or actions set to it , I only use it for my floodlight. I replaced my old dumb switch to the wyze switch that controls my floodlight junction box , bc my floodlight cameras have a pattern of going offline so I use the switch to turn it off and on to do a hard reset to get the cameras back online through the app

Tagging @R.Good here as he may know more here … any help ?

Agreed that it “fixes itself” after another press of the switch, but it continues to happen to me daily. I have a dozen or so Wyze switches connected to Wyze bulbs and it happens to all of them. I have tried resetting the bulbs/switches, but it doesn’t seem to do any good unfortunately.

Thanks! Yes, I have tried resetting the switches and bulbs. Unfortunately, it seems to affect all of my Wyze switches (a have a dozen or so of them).

1 Like

Hi again,

Did you consider this could be a router issue?
Especially considering the large amount of devices you seem to have…

Few years ago, I had griefs with my connected heatpump that kept losing its network connection and forced me to add it back every 2 weeks - but not any other IOTs I had. It ended-up being a router issue. Once upgraded, I never had an issue since.

I could certainly understand it being a router issue. I do actually have two routers to help alleviate congestion. Any ideas on how I could debug or troubleshoot the issue to rule out or identify a router issue?

The odd thing to me is that the switch simply does not respond the first time I press it. It isn’t delayed, the action simply never happens. Then on the second press, the switch works as I would expect (responds immediately). It is as if the first press had to “wake up” or reconnect the switch to the network.

Is there anyway to see a debug log for the switch? Something that would tell me if the press is 1) not registered, 2) registered but not able to be sent over the network, 3) registered and sent over the network but for some reason not performing the action?

I never tried to watch the WiFi trafic with my Wyze stuff.
I’ll check if I still have my laptop with WireShark installed. It could be interesting to see if it can be tracked.
This way, one could know if the switch sent the command or not.

I would be interested to try a well, but I am not savvy enough to try it on my own. If you have an article/guide to show how that might be done, I could give it a try someday!